Scout can't login

When my son tries to login to scoutbook it loads for 30 sec. then shows this screen:

I can login to scoutbook just fine and he can login to so it is not his password being wrong. Any ideas to fix this?
PS: We tried to login on different devices and browsers.

Try logging in on a computer in a private browsing/incognito window. Sometimes random junk in the cache causes issues.

I already tried this in both incognito browser and in-private window.

Bummer. That usually works for me.

Maybe try displaying the debug window in the browser to see if it gives any hints on what’s timing out.

Thanks for the tip! I am not really sure how to do this though. I assume I should use Developer Tools button but I am not sure what the important information is when I open this tool.

Im hardly an expert, I’m afraid. I would look at the duration for each of the operations that’s being executed to see if one of them stands out.

1 Like

@WAScouter if you go to your Scout in Scoutbook and click Edit Profile > if you go to bottom do you see “Invite”? What is BSA # ?

BSA Id is 129018675.

There are multiple logins today with on active one now in SB - seems like something on user side

Well actually seems like they are not expiring/ logging out?

So the problem is that he that he is signed in somewhere else so he can’t login on another device?

@WAScouter not sure on that - am checking with others

@WAScouter odd ??? have they tried login with first letter caps?

I tried that just now and same problem.

@WAScouter OK I see a live Scouting APP session too - can they log out of that?

and log out of my.scouting too



If you need to delete his scout account, that he fine, I can set up a new one for him. I just do not want any advancement info deleted.

@WAScouter I think the best idea for now is forget it till Sunday - let it time out - no more logins

ok will do. I will let you know if it does not work on Monday. Thanks!