Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Microsoft Edge Compatibility

Not sure if it’s a local problem or something else, but suddenly, I’m having problems generating Advancement History reports for my scouts when I use the newest Microsoft Edge browser. It’s always worked in the past, but now, when I request the report, it pops up a new tab, spins a wheel a bit and then posts this simple (but unhelpful as to what to do next) error indicator:
image

Surely more could be offered than “Report could not be loaded. Please try again.”

If I jump over to Chrome Browser and do the same thing, it runs just fine. Maybe a missed an announcement that Chrome was the recommended Browser?

I am a big Edge user. It is not clear to me what exact report isn’t working for you. I tried the “Individual Advancement Report”, “Cub Scout History Report”, and “Scouts BSA History Report”. They all worked.

image

Here’s the sequence in Edge:
I am a Key 3 Delegate as Advancement Chair of the Troop. When I log in I’m seeing this red “Error” box which is new, but no clue what error it might be as I can access the roster, pull up a Scout’s records, etc.:

image.png

image.png

image.png

Do you have another browser you can try? Possibly in an incognito window?

Sorry! I didn’t catch that this was in Internet Advancement. I just tried in Edge, and it worked for me. I even set my dates way back to 2005. I am the Scoutmaster.

So, it isn’t Edge in general. It is either your computer or your unit or your access.

Have tried it on Chrome & it works fine there. Didn’t try it in an incognito window but will do so tomorrow. Thanks for the idea.

Microsoft is doing a slow roll out of the latest version of Edge, so it’s possible you may all be using different versions of the browser, resulting in different experiences. It might be helpful to indicate which version of Edge you are using.

Click the 3 dots in the upper-right corner of the browser, go down to Help and Feedback, then click About Microsoft Edge. I checked my computers and I have version 87.0.664.41, which is indicated as “up to date”. (My computers are running Windows 10 versions 1909, 2004 and 20H2.)

1 Like

I’m running version Version 87.0.664.41 (Official build) (64-bit) of Microsoft Edge and this in info about my H/W & Window 10 version:

image.png

And, the report worked in an incognito window. BUT, it still isn’t working in the regular tab/window. Must be some residual file or setting or cookie issue which I’ll have to look into further. If you have any ideas about what I need to reset/delete, I’d welcome them.

Gary Holland
110 Old Sib Road,
Ridgefield, CT 06877-3042
E-mail: gholland006@gmail.com
Mobile: +1-203-733-5104