Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Needs Approval Report Not Working with EDGE Browser

Needs Approval Report shows “loading” and after several minutes of “loading” no Needs Approval Report is displayed with the EDGE browser.

There is a # after the “Needs Approval” in the Troop Reports indicating there are items to approve.

I waited 24 hours and restarted my desktop. I tried Edge again for the Needs Approval report and had the same results, no Needs Approval report.

I tried Chrome browser and that works but it is slow (“loading” lasts a long time). There is only one item for approval as expected. Troop size is 88 Scouts.

Needs Purchasing and Needs Awarding Reports operate normally with Edge and provided the necessary reports.

Is something timing out with the Edge Browser?

Thanks
Jay

Could you provide a screenshot of what does come up?

I just tried scoutbook on edge and the needs approval came up without issue.

This is the “loading” that takes a minute

Followed by “Error Loading Page” which lasts for a few seconds (I missed this before)

And back to

Attempted corrective Actions:
Restarted PC
Cleared Edge Cache
Verified Edge was up to date
Microsoft Edge
Version 94.0.992.37 (Official build) (64-bit)
Windows 10

Is it possible, it times out and shows “error loading page”?

@JaphetWoolston - do other browsers experience the same issue ? I typically have multiple browsers such a firefox, chrome, opera, sea monkey just to eliminate browser related issues. As this worked for me I suspect we are dealing with a user level issue. Could you post your BSA id

Jeez - missed the chrome thing, but it is not optimal performance.

I suggest trying edge in a private window. Since it is working for you in Chrome, this seems like a browser problem.

You might be able to spot the error by displaying the debugging console in Edge:

I noticed that it takes the computer equivalent of an eternity (38.13s) to return the Needs Approval report in Edge:

Granted, we have a ton of stuff on the list, but I can see how that might potentially trigger a timeout. I’m not sure how to avoid that issue, though.

2 Likes

Did you ever get any resolution on this? I can’t get a Needs Approval Report for our troop either–either on Safari or Chrome. They will load slowly by patrol, but we have a very large Troop and that is a cumbersome way to take care of things. My BSA ID is 137070276.

Thank you,

Lisa Evans
Advancement Chair
Troop 809 San Antonio, TX

@JaphetWoolston @LisaEvans1 I have reported this to the developers. I’m not sure how quickly they will be able to fix this. As a workaround, are you able to look at den/patrol needs approval reports by going to the den/patrol page and clicking on den/patrol reports? I’m hopeful that by being smaller, they’d generate quicker.

Thank you. It works by patrol, but it is very, very slow.

Lisa

Sadly, now I have to take that back. It does not work by troop or patrol. I started going through the patrols this morning, but now it’s not working anymore. I get the spinning circle during loading and then a brief error message. This would apply to Safari and Chrome.

I still receive “Error Loading Page” at the Troop level for “Needs Approval.”

Here is what the “Debug” shows:

image

So I believe something is timing out on the server

I can get the Patrol “Needs Approval” to work. I tried the largest Patrol 15 scouts and that seems to work consistently.

Our Troop is on the larger size with 88 Scouts.

Jay

A backdoor to this would be to use advancements.scouting.org to approve

IA 2.0 is now the only work around. Chrome is timing out as well.

Besides my PC, I’ve tried a laptop and mobile phone all with the same timeout.

Good morning! I have had the same issue since last Sunday too! Tried multiple devices and Chrome just locks up with the loading. Then the whole system freezes up and I can’t access anything - have to log out. Trying to reconcile summer camp MBs and advancements ahead of COH.
Thanks for your help!

Same here. Needs Approval report doesn’t work on Chrome or Edge for last few days. Trying to run by patrol but takes a really long time to run each one and is timing out in between scouts. We have a large troop 125+ scouts. I’m guessing some update was made to the report recently because I didn’t have any trouble for last COH in August (and we had almost 500 items to be approved). Any way the Scoutbook tech people can undo whatever change was made to the report?

Seems large rosters cause it to timeout. Hope they can resolve the timeout issue. Even calling up the roster takes 45 seconds which over time adds up.

Same issue here. Tried FireFox and Chrome. Both come up with the “Error Loading Page” We have ~120 in our troop.

We have 214 Scouts in our Troop and even going patrol by patrol times out. Hoping this gets resolved soon.

That is quite the troop size. I wonder if there are any larger troops in the country? It would be good to hear about any other issues as it would likely test the limits of most of the components of the system.