Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Needs Approval/Purchasing Reports stopped working

I’ve been relying heavily on the workflow in ScoutBook for recording and purchasing Advancements. The reports are no longer showing data today after I created a PO that only included some of the advancements. The Open PO no longer appears. The Approved awards that have not been added to a PO no longer appear. I’ve tried Chrome and Edge browsers with the same issue.

Does the report generate with no awards on it, or is it a blank page?

How many awards were on it?

It looks like you are the troop admin for the boy troop and girl troop. Are you having issue with both or just one?

The report runs and tells me “There are no awards that need to be purchased at this time.” and shows me a link to the Closed POs but not the open POs nor the advancements that are not yet added to the open PO. For the Boys Troop, there are 4 SKUs / 5 items on the Open PO. For the Girls Troop, there is 1 SKU on the open PO. (I saved the PO CSVs before navigating away from that page). There are probably 3 awards not added to the Boys PO and not showing on the report. Sorry. It is happening for both Troops.

The Needs Approval report should show at least 1 Scout with awards that need to be approved for the Boys Troop.

Can you look for the items under the scout’s advancement page, does it show there with a completion date? Is the approved box checked? Awarded box unchecked?

The ranks / awards are correctly showing as Approved under the individual Scout’s pages with the correct date. They are correctly showing as not Awarded.

The Needs Awarding Report shows blank so there is no way to mark them as awarded. This would seem to be an issue with the Reports recently introduced since I have been performing these same actions for each COH until now.

Can you go to the troop roster page? Are the adult names red or black? Can you click on them?

Adult names are black (and not clickable). Scout names are red (and clickable).

So you cannot click on the adult names. Sounds like the same bug some others have seen today. I will ask the developers to look at your account specifically.

Thanks Jacob. Happy to help in any way needed. I can hop on a Zoom/WebEx if needed.

I’ll let you know if that would help. For now, we’ve just give the developers the list of users with similar issues, and they can start sorting through it. I’m not sure how long it will take

Please try again. A fix for an issue with some unit admins was released this morning.

The issue with the Troop Roster page allowing Leaders to be selected (now displaying in red, not black) has been fixed but the Troop Reports are still not working.

From the troop roster page click your name > your positions. Do they all have a green shield by them? If so, click your troop admin position anyway and click update. That sometimes refreshes things.

Thanks Jacob. Yes, everything had the green shield. I went ahead and updated the Troop Admin role and that seems to have fixed the reports. Thanks for all your assistance!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.