Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Needs Approval Report Not Working with EDGE Browser

Until a few weeks ago we never had any issues with the Needs Approval report (or others), although the OA report takes time given the troop size. We rely on the troop Needs Approval vs. Internet Advancement as we can check MBs for counselor approved and other comments. We also have 20+ patrols and going through each is somewhat time intensive.

Very happy to see a yellow information notice line on the top of Scoutbook indicating they are aware of the problem and are working to resolve the “Needs Approval” report timing out. Fingers crossed.

2 Likes

UPDATE — SELF FIX to eliminate the Needs Approval timeout issue (Caution, this is not an approved method but something that worked for me). Here’s what I did:

I approved all items that “Needed Approval” (a few were waiting for the Scoutmaster to approve some Eagle requirements).

After that approval, no items showed up under the Troop XXXX section of the “Needs Approval” report.

I went back to my dashboard and selected my Troop and selected the Report “Needs Approval”. It took 54 seconds.

HOWEVER, I noticed that there were still Total: 20 items that needed to be approved as “Needs Approval”. This Total is on the right-hand side of the “Needs Approval Report”. The “Approve all Troop XXXX” button was present, BUT there were no items listed under the Troop XXXX section. This was a bit puzzling.

I took a chance and blindly approved these 20 items by selecting “Approval All Troop XXXX”, Then I returned to the dashboard, selected our Troop and selected the “Needs Approval” report, it ran in 7.5 seconds!!!

I checked the Needs Purchasing report and nothing new showed up there. So I don’t know what was actually approved so be cautious using this method. Not sure if our data was corrupted or there were items that needed approval but for Scouts who were no longer in our Troop Scoutbook Account or some other issue. Could it be new AOL crossover Scouts who might have outstanding CubScout “Needs Approval” items that we can’t approve at the Troop Scoutbook level?

This is the first time I’ve seen no # after the “Needs Approval Report” when I select Troop Reports. I had always been puzzled why the # remained even when I had approved everything. Now, I’ll look at the number to the right i.e. Total: to see if there is something still hanging on.

1 Like

The developers have reported this is fixed. Could you try your full unit needs approval report now?

@edavignon just tried the needs approval report again and got a Error again. Just an FYI.

We have a big troop. About 120 scouts + 35 adults

A

Thanks @AhmedZaidi. I have notified the developers.

Times out on Chrome with “Error Loading Page” when running as a Troop Report. When running from the Patrol Report, it takes a while, but does complete.

I get the same error message using Edge or Chrome. Same issue as yesterday. Cleared cache and history, no effect.

I tried from my iphone as well, same error message appears (Error Loading Page)

Jacob,

Since I took a gamble to approve Items that were only identified by the Total having a number with no listed Completed Requirements, my situation was resolved by me several days ago. So I have no way of testing whether the developer’s fix works. By the comments below your comment but above mine, there may be other issues with the Needs Approval Report that the developers need to resolve. Likely for large Troops.

1 Like

any update on a timeline, it’s getting close to the end of the month and we need to be able to approve our Scouts advancements and submit our orders to the Scouts Shop? Its still failing again this morning.

Eric, You might try this:

Go to Internet Advancement (assuming you have the privileges in IA 2.0).
(You can do this by logging in Scoutbook and selecting Internet Advancement or from my.scouting.org and the menu)

Select the Pending Items tab (next to Troop Roster tab)

Approve the items you want to approve.

Return to Scoutbook and select Needs Purchasing and you should see all the items you approved.
Add new items to your open purchase order.
You can print out your purchase order
Close the purchase order

Select Needs Awarding to record those items you award.

Good Luck.

Jay

Hi Jay,

I was able to approve the completed items from there, however when I go back into Scoutbook, it still won’t let me access the Needs Approval Reports section.

Accessing the Purchasing section isn’t an issue…. For now :slight_smile:

Eric,

Glad this work around allowed you to approve the items. (For others who are following, this link is a direct link to Internet Advancement 2.0 Internet Advancement ).

My guess is that you have some “Ghost” items that need to be approved. By that I mean items that still need to be approved but are for Scouts who are no longer on your roster (either transferred or dropped off your roster at recharter) or possibly it is for an award that was phased out. The trouble is that you can’t get to the Scoutbook “Needs Approval Report” to clear them as these don’t show up in IA 2.0. Sort of a catch 22.

I was only able to get the Needs Approval Report to work after approving everything in Internet Advancement. Then went back to Scoutbook which finally allowed me to run and view the “Needs Approval Report”. It was at this point that I saw a number in the “Total” box to the right of the Needs Approval Report but NO items were listed in the Troop section. I selected the button “Approval All Troop ####” and it cleared these Ghost items and Needs Approval runs at the same speed as Needs Purchasing or Needs Awarding. I haven’t had a problem since.

Without knowing the code/database structure for how Scoutbook processes Needs Approval items, I’m really just guessing.

Good luck.

Jay

Are you able to approve anything still in there and push to the open PO?

I image anytime left are items within beltloops that are partially completed.

Eric,

It is hard to determine what is still in the Scoutbook Needs Approving section of Scoutbook when you can’t access the Scoutbook Needs Approval Report because it times out. Scoutbook allows you to approve individual requirements (Merit Badges requirements, Advancement Requirements, Award Requirements) while I believe Internet Advancement only allows you to approve completed Merit Badges, Advancement, or Awards. Could be the requirements that is tripping you up. If you can go into the Scoutbook Patrol Needs Approval Report, you might see them there and approve them.

When the Cub Scout AOLs transferred to our Troop, some Cub Scout had Cub Scout requirements that needed approval and I approved them as there was no other way to clear them. As I recall it was cyberchip and World Conservation requirements. Since they were not completed awards, nothing showed up on the Purchase Order.

We have a large Troop (88 Scouts) and before I assumed Adv Chair in April 2021, the Troop shifted from TroopMaster to Scoutbook in March 2020. Perhaps there was something left from that transfer. No one can really tell me the process they used to convert to Scoutbook. The Troop was using a combination of IA 2.0 and Scoutbook before I took over. There were over 1000 items that were in the “Needs Awarding” report that had already been awarded just before I took over from the previous Adv. Chair. I’ve managed to clean everything up and now the Needs Approval Report runs in seconds.

Good Luck. Hope the developers can find a way to correct the timeout issue.

Jay

In my experience, the items that add to the needs approval count but don’t show up are related to scouts who are on the scoutbook roster but not our official roster (and therefore can’t be approved).

The developers are aware of the continued issue. They made some improvements but apparently it wasn’t enough. This is a tough one to test because the test environment is generally slower than the production environment.

Hi Jacob,

Just for a data point. Our Scoutbook Roster and Official Roster (my.scouting.org) match. All Scouts in Scoutbook are Autosynced.

Jay