Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Needs Purchasing/Awarding Report not showing

The “Needs Purchasing” and “Needs Awarding” reports aren’t an option when I click the Pack Reports button. Have these moved some place? I’m an experienced Scoutbook user and just noticed this issue the other day.

I still see it under pack reports. Are you a pack admin? Does the position still appear with a green shield?

Yes, I’m one of only 3 people that regularly uses Scoutbook in our Pack.

When you look at my dashboard > reports menu, do you see them?

Are you on a Scoutbook roster for another unit?

I’ve tried logging in through IE and Chrome and the issue still exists.

See below. I should not be on another units roster.

Try going to My Dashboard → My Units → Unit Roster → your name, then select your Unit Admin role, check position approved, and click update. That has helped reset permissions in the past.

That did not work either.

Can you go to my dashboard > my account > my positions, and paste a list of your current positions?

When you clicked update on your admin role, did you use the exact path Charley suggested? It makes a difference?

Yes I followed that path. Here are my permissions:

Are you running the Feature Assistant Extension? I want to rule out any interactions if possible.

Not running any extensions. I’ve also tried on mobile with the same results.

Are you able to access connection manager from the pack roster page and confirm that you have full control of all scouts?

Yes, I do have full control

go to My Account > Switch SSO Profile > try that. I think you have 2 BSA numbers

So you need to go to my.scouting.org and make sure your login shows the unit you want, then do Switch SSO with that log in

The BSA number in Scoutbook matches my my.scouting.org BSA number. I did have two number because our controller created a new number for me when I registered with my Lion as their adult partner. I removed the second number at recharter. I have not had this issue until after the first of the year. I don’t think my council has processed my recharter yet because old members are still listed in the roster.

I also never logged into or added myself to the Pack’s scoutbook roster with that newer BSA number. It’s not associated with my pack in the roster.

Can you try something else? Go to any requirement on a scout who is not your own child. Mark it complete with the approved box check. Let us know what happens.

When you click my dashboard, does your pack show up under my units? With and A with and arrow circling it?