Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Not receiving emails from Scoutbook

Hi, I’m not receiving any emails from Scoutbook. I’ve had a few people send out Troop and Pack emails, and I’ve even tested sending emails to myself, and I’m not receiving anything. Others Pack and Troop members are receiving emails.

Does anyone have any suggestions for how to resolve this issue?

first go to My Account > Click email - see if it is correct and see if the Opt-Out is checked.

Second check your junk mail at the server NOT the client like outlook

Hi Donovan,

Thanks so much for your quick response. A few more pieces of information for you:

  1. Opt-Out is not checked
  2. I have checked my junk mail at the server, and the emails are not there
  3. When we tried sending a test email from my wife’s account to both my son and I, two interesting things happened:

a) We could not send the email at first. We were getting an error message that for Youth Protection purposes we had to add another adult’s valid email address, and

b) We added an additional adult (one of our ASMs). I did not get the email, but my son did. When we checked who it was sent to, my email address did not appear in the “To:” line (just my son, my wife, and the ASM)

Do you have any other suggestions?

Best regards,

Paul

@PaulArhanic hmmmm - that is a good one - can you try again I just tried a little hack to see if it works

Hi Donovan,

Thanks! I just tried again, and it looks like it worked (I saw that you added a “+1” to my email username).

Please let me know if there is anything else that I need to do.

Also, do you know if this is an issue that is isolated to my account, or is this something that may be happening to other adult accounts in my units?

Best regards,

Paul

Fix was a shot in the dark - BUT I am in SUAC cause I can guess SB Hacks - LOL. I even bet you could change back and be fine. I am very glad it worked

1 Like

Hi Donovan,

One more quick update for you … I tried changing my email address back to the original (i.e. without the “+1” ending to the username), and Scoutbook reverted back to its old behavior (i.e. it would not send me emails)

I added the “+1” back in, so the messaging functionality is currently working for me; however, I did want to let you know since the underlying issue (i.e. not recognizing my valid email address) has not been resolved.

Thank you again for your help with this issue!

Have a great day!

All the best,

Paul

yes I will send a note to Developers

@PaulArhanic when the email is NOT +1 - and you try to a message to you (or someone testing might be better) - and you turn OFF BCC - is the email listed? @edavignon

Hi Ed,

No, it is not. We’ve tried sending messages from my wife’s account to me and my son, and the following two things happen:

  1. We get an error message that for Youth Protection purposes we had to add another adult’s valid email address. We can’t send unless we add another adult.
  2. Once the second adult is added and the message is sent, my email is not listed. (BCC is turned OFF in this case). Email addresses shown are my son’s, my wife’s, the second adult’s. Mine is not shown.

When you add the “+1” suffix to the username, the system behaves as expected (no YPT error message, the “+1” email appears in the “To:” line of the email, and I receive the email.)

Please let me know if you need any more information.

Also, if you think it would be helpful, I would be happy to set up a time to meet live, and I can share my screen to show you in real-time what is happening.

Best regards,

Paul

Not sure on YPT stuff - but thanks for the info on NO BCC

Do you know how to view RAW Source for an email - that might be interesting on one that does not have your email - if so I can make a Direct message to send it to us

My guess is that the YPT error is happening because the system isn’t recognizing my email address as a valid one.

My guess is that the system does a check to confirm that when sending an email to a youth, there are two adults on the email. I think we’re getting the error because when my wife (adult) sends an email to my son (youth), the system isn’t recoginzing my email address as a valid adult email (which would be required for the “no one on one” YPT rule)

I don’t, but if you tell me how I can try it.

@PaulArhanic most Mail Client Apps it is Menu Bar > View > Message > Raw Source - would need to be from your Wife’s computer or Scouts - as you did not receive email

I agree with that assessment. It’s more good info we can provide the developers.

@PaulArhanic I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC) to keep your info confidential

@PaulArhanic did you EVER ONCE set the no email switch in Scoutbook?

To the best of my recall, I did not.

i am having the same issue…the opt in is set and still not receiving emails :frowning: