Online training not loading

I tried to load safety afloat and hazardous weather training and when I click on them, there is an infinite loading screen. The Wi-Fi at my house is good. Other sites work fine. I’ve tried 3 different browsers (chrome, edge, firefox) and tried loading it on a different PC…Nothing is working. Seems like it could be a hosting issue.

Same issue. Just received an email reminding me to renew my YPT, but getting a 404 error for every single course


We are getting more reports than just these. When I clicked on Hazardous Weather (latest version of Chrome) all I get is a spinner.

BSA IT is aware of the issue and investigating.

1 Like

BSA IT reports the issue with the training site is back up. I was able to get to the Hazardous Weather Training now when I could not earlier today.

I am also seeing issues today. I started, very briefly, my YPT renewal yesterday but was unable to complete it. Today, I came back to it, and getting a 404 error when trying to access the training center.

My husband tried to do YPT tonight and couldn’t get into training. We were both able to log in to my.scouting, but neither of us were able to load any trainings or see the catalog. I hope IT can fix this quickly.


I have reported this to BSA IT.

Training is working again this morning.

I too have tried to complete my YPT training and have tried on multiple computers on different networks and get the screen where the video would play, but nothing shows up. Tried this on multiple chapters of the training and always get the same thing.

@RonPlunkett - what browser are you using?

I’m using FireFox, but also had the exact same issue using Chrome

Training is only supported on the latest versions of Chrome and Edge. Try using a Chrome incognito window. If it works there, you have a cache, cookie or extension that is interfering with training.

1 Like

Didn’t work with the latest version of Chrome, but Chrome Incognito worked

In that case you have an extension that is interfering with training or a corrupt cache or cookie since incognito runs with no extensions unless you have specifically enabled them, a clear cache and no cookies when the session starts.


In case you’re curious which extension is causing the issue, @RonPlunkett, you can enable them one at a time in incognito to see when training “breaks” again. That might allow you figure out if it’s something you could disable without having to go via incognito mode to do training (versus a cookie/cache issue, where you’d likely need to clear those items, which could have unexpected consequences if it’s a cookie needed for another site, for example).

1 Like

I have tried three different browsers and three different devices along with Incognito/Private modes and none of the training videos will load and play.

@shigadeyo - which training is this?

@shigadeyo Which browser are you using?

All. I was finally able to get it to work on a twelve year old Mac AirBook using Safari. At the moment, no variations of Chromium or Firefox seem to work repliably.