Parent and den leader/advancement chair cannot approve adventure for my child

Hi! I’m a den leader and the pack’s advancement chair. I can approve adventures/requirements for any scouts other than my own children. This probably wasn’t intended. Please fix. Thank you!

Make sure in the top right Drop down your leader position is selected and not your parent

Hi! Thank you for your quick reply! Den Admin position was selected. Should that not work?

@CalebChristopherson should work - I can setup a fast screens share if you want

Sure, I can show you a couple other things too, if you’d like.

I will send you a direct message > look at top right Avatar to find it > it will be a green envelope > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

Hi, I have my leader position assigned but our newer scouts, I tried to quick entry their fishing adventure as we went fishing as a pack and it says their rank doesn’t exist. So, it gives me an error.


Are these new Scouts in a den?

Hi, We have the same problem here. And we have done the different drop downs to change from parent to BSA title and nothing works. Any other suggestions? or is this a bug that will eventually be fixed? Thank You

Yes, brand new to scouting.


Can you post the scout’s BSA Member ID (not names). Someone will investigate.



Thank you


One thing I notice is these Scouts are in different dens. Did you use Quick Entry for the proper rank version of the fishing adventure for each?

I also see that the Wolf den does not start with a number. Currently only Webelos dens do not require a leading digit in their name. I wonder if this could be causing part of the issue.


Are these Scouts on the 2024 version of rank and adventure?

I clicked into each scouts individual adventure and tried the wuick entry that way.

Yes, I made sure it was 2024


Thanks. I have passed this on for investigation.

Can you try quick entry from the red bar on the roster page in case that makes a difference?

@jacobfetzer @edavignon, jacob’s suggestion worked. Thank you!

okay…wait it did not work for my new ones. It said it did but it did not. It worked for the others.