Parent Connection issues

I am trying to get a parent and step-parent connected to a scout in scoutbook. I previously added them a while ago and sent the links out, but they did not complete the process on their end. Now they are asking again how to get in to scoutbook and the system is telling them they are using an incorrect login. Both still say pending under connections, but one shows up as connected on the scout’s page. I have tried sending the links again but it is still not working. I made the suggestion of resetting the password and one of them stated that they tried but it just “spins”. The other as far as I know hasn’t tried resetting yet.

I don’t THINK they have done the login with google thing, they are both using Yahoo email accounts. I could be wrong there though.

What is the consequence of just deleting the connection and starting over again? If I delete the connection does it get rid of the account too? Thanks!

@MatthewShannon Please post the Scout’s BSA member number, and someone can take a look.

(No names, please.)

140833838 is the Scout.

@MatthewShannon I do not recommend creating accounts for adults in Scoutbook, because this process creates a new username at my.Scouting and a new BSA member ID number with a blank date of birth. In this case, both parents already had a username and a BSA member ID number.

Please ask them to try logging in to their accounts at my.Scouting with their my.Scouting username – not their e-mail address. If they need to reset their password, ask them to use the chatbot (“Betty”) at my.Scouting. If they are still unable to reset their password, your local council can do a direct password reset.

After they log in at my.Scouting, they should be able to click on:

BSA Web Links → Scoutbook Plus

When they get to the login page for Scoutbook Plus, I would recommend clicking on: CTRL+Shift+R (all at the same time), which should force a hard page reload / refresh in their browser.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.