Parent not able to record their scouts advancement

I have a parent (BSA ID 14413544) who has tried to record some of his scouts advancements, but gets the following error: “Whoops! It looks like you are not able to record advancement as a youth. We will save your information, but this will not go to your leader for approval. Please review with your unit leader.”
I checked the profile and he is listed as the parent of this scout (BSA ID 14307102) and the permissions appear to be set correctly. I’m not sure what else to do.

typo on the parent ID. It’s 14754849.


The last time the individual with BSA Member ID 14754849 logged in to Scoutbook was December 4. The ID is Firstname.Lastname. Please confirm he is logging in with the proper ID.

I just asked the parent. He verified that his login is Firstname.Lastname and he is currently logged in through the Scoutbook app. That BSA ID is what the app shows him.

Please ask him to try logging in to instead of the Scouting App and let us know if this works. This will allow us to narrow down the source of the problem.

He logged into the website and it worked fine. It appears this is limited to the app.

Thanks. I have reported this to the developers.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.