Parent unable to login or reset password

I have a parent whose email appears to be correct in scoutbook, but only gets the message "“No accounts were found matching the information provided.” when she tries to use the forget password/username link.

BSA Member #: 13211143
UserID: 2291233

Please let me know if you can help get this resolved. Thanks!


Is the parent using the Forgot Password option (on the right) or forgot username (on the left)? There is no date of birth in the parent’s record so the forgot username link won’t work.

I was able to send a password reset e-mail using the Forgot Password option. Have the parent check their e-mail. Their username is their e-mail address.

Thanks, Ed. They received the password reset email, but when they tried to use it, they got the attached error message about an expired token (it’s definitely been less than 24 hours):

Can you provide their username so that they can reset it themselves (or email their username to that email)? I’m happy to vouch for them, or have them email you from that email address if you need additional verification.

Appreciate your help!

Some text because the post can’t be empty.

I’ve followed up with the parent, and they’re able to trigger a new password reset email, but every time they do so, they immediately get the “expired token” message (as above). They’re happy to provide more info if it’s helpful - would OS, browser info be at all useful here?

Have they tried closing all browser windows and then using a private browsing or incognito window?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.