Parents unable to view their Scout's profile

I have reported this issue to my local council but thought it would be good to post here also. It appears that none of my non-leader parents can view their scouts profiles. They are showing connected correctly in the system and they are receiving email from Scoutbook however their scouts are not listed under the My Dashboard. All they see is Administration - My Account, The My Family portion is missing.

Anyone else having this issue? It was just brought to my attention by a parent who was trying to assist their scout with completing their eagle application and need several dates.

I have confirmed this issue impacts all my non-leader registered parents.

post one of the effected Scouts BSA# here and we can take a look

124645044 is the number for the first scout that was reported to me.

ok might be recharter but mother has a few accounts

I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

Hi there. I am having a very similar problem. Let me lay out all the steps taken so that the typical responses aren’t thrown out as solutions.

  1. I can see my scout in ScoutBook through the website program - (not really efficient, but a decent program and service).
  2. I can see that I am linked to my Scout in the Scouting App on phone
  3. Clicking on my scout shows no Council or other information under “View”
  4. Clicking on Advancement closes the program
  5. I have logged out and selected delete data
  6. I have uninstalled and reinstalled the app
  7. I have our amazing Council Sr. District Executive helping out on the back-end to check BSA IDs and links. She even called National and talked to them about the issue. They would “look into it and get back to her regarding my issue.” The response was to log out and delete data (had already explained on the phone that I did that and more) and to post on the forums. …
  8. Contrary to a response above, this is not related to recharter as it has been happening since last fall with no resolution.
  9. I am Cubmaster and also have all the permissions I am supposed to have, so the fact that I cannot see my own scouts info is concerning from a IT programming perspective.
  10. I code and understand the nuances of programing and apps. I would appreciate a legit and helpful response instead of suggestions for things I have tried multiple times with no change.
  11. I have not been able to find anyone in my pack and many in the troops that use the phone app because of the issues. Additionally, the login programming is clunky… When you click on the password or enter credentials boxes, it should be active, not twice to leave the data entry from one field (name) and then again to enter the box to type password or click twice to credential… There is no save password box either, so when the app crashes numerous times while trying to troubleshoot, you have 6 steps to log back in. Not efficient at best, total frustrating at worst…

Thank you very much in advance!

1 Like

Can you clarify if the issues (3 & 4) only occur in the app? That’s what it seems like from your post, but it makes sense to be sure at the outset.

Assuming it’s the app, I’m sure that the folks from SUAC will want to know what platform and version of the app you’re seeing the issues with.

If it’s the app only, then your leadership role (theoretically at least) should not be an issue, since the app is only meant to work for parent/scout connections, not leader/scout connections.

You mentioned that you had interacted with your council leadership about BSA ID checks in 7. Did they verify both that your scout didn’t have multiple IDs and that you didn’t have multiple IDs? We had a parent who had multiple IDs, which caused issues with properly connecting to their scout in the app, but apparently no issues in Scoutbook. We’ve also had scouts who had multiple BSA IDs, one of which was correctly associated to the unit and the other of which was correctly connected to the parent. The latter caused issues that sound similar to what you’re describing. I wanted to verify that both of those potential issues had been ruled out by what you described in 7 to avoid overlooking something.

Hi Charley.

Yes, that is clear. #1 outlines the difference between the website and the rest are the phone app.

Iphone version 11.2.1. I have updated the phone software in the past and tried the app. no luck. Probably need to do another update.

Yes, Our Sr. District Executive confirmed the IDs, relinked them., etc. They have done everything to check on their end. We are fully aware of the issues with multiple IDs (that is a bigger conversation that BSA needs to deal with). Again, this has all been checked and verified…

what is one of the BSA #s you are having issues with? all we need is the #

My legit number is 134089259.

(**Aware that a second BSA ID had been set up by National when I had earlier ScoutBook issues as Cubmaster, but that didn’t work of course, and National and our DE corrected it in April 2020). Again, re-confirmed yesterday that the BSA IDs are accurate and linked. Our Sr. DE unlinked and relinked my scout and still not working. Thanks

Thank you.


You are connected to 1 child with first initial L. Is this correct?

what user name are you using to login @JamesWinslow ?

Yes. L. one Child. Thank you (filling out the required post of at least 20 characters…)

@jewinslow. same as my.scouting and

Hi, I have a parent who reached out to me last week with the same complaint. Her scout’s is ID 135787256. Can you help regain her access?


I have sent you a private message so we can discuss details of this issue. Please click on the green circle with white J in the upper right of your forum window.

I have the same issue. One of my scouts shows up in my website account and the other does not. It’s been this way for four years. Same line as above - no multiple BSA numbers or anything like that, everything correct in Scoutbook, etc.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.