Picture comments links broken

The last few weeks, every time I upload a picture (with comment) in the rank advancement and/or merit badges, but the picture after I post it will not open. It shows a broken link. I have tried this on my phone and on a laptop. I have cleared my browsing history and tried using in private mode, but it is still happening. I have spent hours trying to post the things I need to post to no avail.

This was reported to developers last week.

1 Like

I assume everyone is still having this problem (I know I am)?

1 Like

@JonEberhardt

When this is fixed it will be reported in the change logs.

In case you aren’t already familiar with the process, there’s a post in this thread about how to subscribe to the change logs:

https://discussions.scouting.org/t/unable-to-access-internet-advancement-all-of-a-sudden/311001/30

If it helps, it appears that pictures on older comments are still accessible. I also tried using the URL of the image copied directly into my address bar, and that worked for pictures on older comments. The example I tried was from two years ago.
For pictures I am posting tonight, I get the broken link, and when I copy the URL of the image there directly into my address bar, I get the following:

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>3J5QT72AW6EM5PRX</RequestId>
<HostId> there was a value here I snipped out </HostId>
</Error>

I compared the URLs of the working and broken images, and they looked similar… the only part I couldn’t compare was an 8 character hexadecimal value near the end of the filename. So, unless that value is broken, I don’t think the URL is getting munged. If I were to guess, maybe there’s something about file permissions or ownership when the file is getting saved that is no longer set correctly. I suspect the problem isn’t on retrieval because I can retrieve another image, and both images are in the same URL path, though I suppose the back end could be parsing the filename into some sort of path structure as well.

Obviously, I don’t actually know how your software works; I’m just hoping that my observations and guesses make figuring out this bug easier.

Edited post to get the XML response to show tags, and to get it to be formatted like code, which I didn’t know I could do the first time.

1 Like

It has been 26 days or so. Is there any ETA on a fix for this? This functionality is an important piece of our process. Because the interface for recording advancement is inconvenient at best, we typically mark a rank 100% complete and then stash a picture of the Scout’s handbook page in the comments. Similarly, for merit badges, we put pictures of the MB card in the comments, just in case the Scout’s copy is destroyed or our Troop records perish in a flood (it happens).
This is especially bothersome, since the broken functionality represents a regression. I’m not sure what new features came with the break, but I would prefer reverting to a previous version of the software with the picture upload functionality intact (not that I get a vote). Thanks!

The BSA does not comment on when issues will be scheduled for development work. When it is fixed, it will be announced in the Scoutbook change log.

1 Like

I came here to see if I was doing something wrong … but it looks like other people are having this problem and that it’s been known for a month or so. I’m just chiming in that this is an important part of the process for us, too.