Quick Edit area just disappeared

@CharleyHamilton - certainly, I am seeing full function on: AWSWEBSCTBK2A

1 Like

AWSWEBSCTBK2C And my Quick Entry was visible

1 Like

Ok, so @Stephen_Hornak and @ZacharyMcCarty are hitting the same server as @JulianaRather, and getting full function. That does seem to rule out server as the issue.

@DawnSelly and @JulianaRather, have y’all gotten any new scouts in recently? Maybe Scoutbook is seeing a scout for whom y’all don’t have proper connection/permissions, and preventing you from accessing the quick entry tool since you don’t have the right permissions.

I have a new scout but I can access her individually and have full permission

Another perfectly good guess shot down by the facts! SUAC, any other thoughts?

Hi, @JulianaRather and @DawnSelly:,

I just realized that you also appear to be missing the Troop Reports menu item, in addition to the Quick Entry and Import Black Pug menu items you mentioned (last snapshot is my interface with the extension installed):


I believe at least one of y’all mentioned that you tried from a mobile device as well, and that you were still missing Quick Entry.

Have you tried going into My Dashboard → My Units → Unit Roster → Your Name, clicking through to Positions, and selecting your Admin roles (and/or your Scoutmaster roles), then select the “I agree to join the unit roster” radio button and clicking Update? I wonder if your positions aren’t showing as approved on the back end, even though they look right on the front end. I’ve had that happen a couple of times, and “updating” the positions has generally helped resolve the issue (or at least rule that out as a cause). I’m not sure if this step was already suggested, so my apologies if I’m being redundant.

ETA: Revised path in bold above to reflect comments by @JenniferOlinger in this thread. Apparently, the process is path dependent.

@CharleyHamilton - this indeed seems to be user based rather than platform or browser centric. The suggestion to update the position is one that may well kick the issue over to resolved. I would also like to know what other unit admins in the unit see.

Tried it but it didn’t seem to work

I too am trying to access quick entry but it is missing. I’ve read the posts on here but don’t understand the extension or import black pug data that is referenced. Not much of a technical guy so the talk about servers is over my head. I did update my position but still don’t have the quick entry option. I just want to be able to use ScoutBook efficiently.

1 Like

Is Quick Entry and the reports missing from any of you with the extension disabled or removed? If so do you have a boy or girl troop?

Two things of note on this problem which I am continuing to experience. First, clicking the “agree to join unit leader roster” button is not saving for me. Note that the green arrow isn’t checked for me.


Then I click the agree to join roster button and it is checked.


Then when I go back to it again it shows unchecked again.

The second thing is that there was no Troop Forum for my unit, so I found a way to add it through Internet Advancement. A forum was added, but it seems like it may have corresponded to the loss of quick entry ability.

Look to see if the dashboard says Feature Assistant active at the bottom. I am on the road now, can help more in about 45 minutes

Scoutbook changed something in the way it loads pages. I have randomly seen issues where the extension appears to load earlier than a crucial Scoutbook file it is dependent on.

I have a potential fix being tested by the SUAC but so far no one in the SUAC has even seen the issue except me. Once I get the ok, I will release the extension update.

1 Like

All the Feature Assistant menus are gone for me as well. Running Win 10, Chrome 76.0.3809.87, Firefox 68.0.1, and Feature Assistance Connected to server AWSWEBSCTBK2A and feature assistant show active at the page footer. SM (default), MBC, and Troop Admin positions. I have also selected the agreeing to join the unit roster and updated it under each position. I was affected by the login issues earlier this week (password wouldn’t work on scoutbook, but would allow login to scouting.org).

Check your Send Messages page and see if it shows the Extension features, like groups.

If it does, then for you I suspect there is an issue with the extension reading your position from your My Positions page

OK. Actually the MBC quick entry and Send Message functions do function. No other Quick Entry or Black Pug options. I removed both the SM and MBC positions, logged out, and added just the SM position. No change. I’ll wait for the extension update before trying again. Thank you for all of the suggestions!


You do not appear to have a troop-position registration in the BSA membership database.

In my.Scouting Member Manager am only seeing you registered as a MBC which is a district level position…

That might be a factor affecting Scoutbook access. I understand Scoutbook is now using more information from the BSA membership database to control access.


I noticed my Quick Entry was not in my menu for our Troop but it is still there for the Pack. I had access to this very recently. I am on server 3c for both of them. I removed then added back extension, cleared cache, deleted cookies and all the normal stuff but no button. I am admin on both units. Nothing has changed from the last time I used this feature.

The missing QE and Reports menu issues are being looked into by development. This being Sunday it may be a couple of days before it is fixed.