BOY SCOUTS OF AMERICA

Scouting Forums

Quick Entry is Gone

I am an assistant den leader and enter my den’s progress on adventures. However when I went to check off some requirements after this past week’s meeting, I could not find the quick entry button. I had to enter the den’s progress one scout at a time, and I was unable to mark the requirements as approved.

I have already tried going to my position, checking the checkbox, and clicking update to see if that would fix it. Did this functionality get taken away from assistant den leaders?

Where are you looking for quick entry? Have you tried from the bottom of the den page?

Are/were you also a den admin?

It used to be available on the top of any of the scouts’ pages and adventures/awards. The den no longer shows on my dashboard, but I am still connected to the individual scouts.

How can I check if I am a den admin?

I am not listed as a leader on the pack roster, but my position is still on my positions page.

It won’t show up for anyone without the proper permissions. I’d ask a pack admin to approve your ADL position and make you a den admin.