Recharter problems with multiples and adding existing members

We’re working on the Troop recharter and having a few issues. We tried this logged in as myself (K3D) and as the CC. Both logins result in the same issues.

  1. I’m trying to mark several adults as multiple from our linked B troop. The B troop does not appear in the list of units to select from. But our G troop does appear. That doesn’t make sense since I’m working on the G’s charter. (Both B and G troops are chartered to the same CO and have the same unit number)
  2. When trying to add existing members to our charter, we’re getting an error

The person should exist in the current unit roster with this Member ID

. We got this same message for 7 different people. I’m an OA adviser and was able to use lodgemaster to verify that their BSA memberships are indeed current, and that I have the correct info. Oddly enough 3 other adults worked correctly.

@JonChuchla - talk to your council as they would mist likely need adult application for the other unit.

Beyond that the official bsa roster of current members is at