Remove From Troop Warning

I was cleaning up our roster and removing several Scouts that have not been active for a long time. About halfway through I noticed there was a checkbox that I could select to stop giving me the warning about removing Scouts from the Troop. I selected it to streamline the process and instead of not giving me the warning it actually stopped me from removing Scouts all together. This was clearly not the desired result.

Ho can I get the ability to remove Scouts back. When I enter a date now to show their end date of membership it just does nothing.

Maybe clear cache? or try an incognito window

Incognito worked. It is still something that should be looked at. Clearly the user wants to not have the warning rather than have their ability to removed Scouts disabled.

am testing it - I am just not seeing that behavior yet

Where is that? A screenshot could help (without displaying names).

Of course the SB behavior is different all the time. Sometimes this warning shows up when I put todays date in to end their membership. Sometimes it doesn’t. At least once it showed up with a tick box to prevent it from coming up again.

The tick box doesn’t show up in incognito and of course I can’t do it in my normal window because when I put today’s date in to end their membership it does nothing…because I checked the box to not show me the warning.

I suspect that is part of the feature assistant extension. @GaryFeutz any thoughts?

I don’t understand why the ability to remove a scout isn’t working, but the warning is for folks who are intending to move the scout to another den/patrol. If you put an end date on the membership in that case, rather than using the transfer into den/patrol tool, the scout’s membership may be erroneously ended altogether.

Not part of the extension…

They are no longer with our Troop and we are trying to get them off our Scoutbook just to get it cleaned up.

Hey Gary, not sure what you mean . Indefinitely check a tick box in one of these warnings because it said “check here to prevent Scoutbook from displaying these messages” and after that when I put a date in to end their association with the Troop it does nothing. The warning doesn’t pop up, but it also does not remove the associaiton.

Jacob thought the issue might be related to the Feature Assistant extension. It is unrelated to the extension.

@ReidHollander - are you running a popup blocker or have a browser setting for pop-ups

I am but it was working fine before ticking that box and it works fine in incognito even with ad blockers on.

Sorry, but I can’t not make the comment that the checkbox did exactly what it said it would. As you can’t remove any more Scouts you will no longer get the warning. Maybe one of the programmers has a warped sense of humor.

I also can’t remove any Scouts. It sounds like Scoutbook is just giving up on the issue rather than take the feedback that it doesn’t work as anyone intended.

It sounds still like something with particular accounts. I removed a number of Scouts and adults last week.


No one is giving up. The problem is no one on the SUAC has ever seen an option to stop presenting the warning and we have not been able to duplicate this despite multiple attempts.

Have you tried clearing your cookies on the browser where you are having the issue?

@ReidHollander - here is my thought… as this works when in incognito mode and nobody can replicate your issue it is a problem with your browser.

I’d give them a bit of time.
This is like an intermittent electrical problem. Easy to describe, but a pain to figure out.
Kind of like our microwave outlet not working after I recently cycled through the breakers. My wife isn’t too happy.