Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Remove Merit Badge

How do I remove a merit badge that was accidentally entered and marked as leader approved? I see previous topics on this and the instructions are not working. I am a troop admin and the advancement coordinator accidentally entered a merit badge for the wrong scout. I am trying to remove it but it will not let me. If I uncheck the box that says “Leader Approved” and click save, it does not change the status. If i click it again, it still shows as leader approved and won’t let me remove the date or click remove merit badge.

@RobertBrodner Are all of the merit badge requirements marked off as completed / approved? It sounds like the merit badge is auto-completing. Try removing the date from one of the individual requirements, first.

1 Like

None of the parts were marked. She just marked the whole badge complete at the top.

I just tested it, and the process worked fine from my end on a live scout:

  1. Marked only the “top line” complete and Leader Approved.
  2. Hit save. Now the MB shows up as Complete and Leader Approved.
  3. Go back in to the merit badge and uncheck the Leader Approval. Save.

  4. Go back in to the merit badge and remove the date. Save. The badge is now removed.

OK, well I did the same thing about 100 times in the last hour and it’s not working for me. Maybe the same person that marked it approved had to undo the approval?

I even tried the trick of resetting my permissions by updating my position as troop admin in my account and logged out and back in. No luck.

You said you are a Troop Admin, so you should be able to remove it.

Shouldn’t be. I’ve done it on other scouts before.

Try going to My Dashboard → My Units → Troop Roster → Your name → Troop Admin

then make sure the Position Approved box is ticked and click update. Sometimes that gets the connection/permissions refreshed in Scoutbook.

Yeah I tried that already. Didn’t work.

It will let me change the date, but not remove the Leader Approved.

What is the name of the merit badge?

It is Composite Materials

So, I tried it just now on a badge that was Leader Approved and marked Awarded by our advancement coordinator, and the process worked fine again. There has to be something else going on here. @SUAC, any other thoughts?

And it was just done today, so it hasn’t even synced with database yet.

OK, I went to a different badge that was leader approved and I tried to unapprove it. Same thing. Wouldn’t let me do it.

I added the position of Unit Advancement Chair to my account and it let me do it. I guess being troop admin isn’t the trick?

@RobertBrodner What other position(s) do you have with the troop?

Now that’s interesting. I’m also a Key 3 Delegate for my unit, although I never had a problem editing foul-ups before I became a K3D.

FWIW, I tested it with the Composite Materials MB and was able to add and remove it. I don’t have any scouts who already have this badge, so I can’t test removing one someone else Leader Approved.

@RobertBrodner By any chance are you a Unit Scouter Reserve in the troop in Scoutbook? That position / role in Scoutbook is not normally able to mark advancements as Approved. As a Troop Admin, you should be able to, though.

Yes, USR and Troop Admin