Run report not working

We have not had a COH since December 2019. When I try to run a report to finally purchase awards, it tells me in the information is not available. I tried breaking the date into smaller increments, same result. Any ideas?

I also can’t open a previous report.


There is a known issue with units that have expired and have not had their 2021 recharter posted. This could be what is causing you not to be able to run the report. I do not know when the problem with expired units in the grace period will be fixed.

As a workaround, I suggest logging in to Scoutbook then going to My Dahsboard → Reports → Needs Purchasing. You can generate a Purchase Order and Advancement Report from there.

Thank you. Unfortunately our Troop does not use Scoutbook, I will contact my Committee chair about when the recharter will be complete.

The database that is used by IA2 ( is the same as the database used by Scoutbook ( Any advancement data that has been uploaded to IA2 should also be reflected when viewed from the Scoutbook interface.