Scout not in Scoutbook (but is in roster)

I have a Scout in my unit who was registered in the fall and has still not appeared in Scoutbook. He appears in my unit roster in ((removed by Moderator), member ID 14485912). He does NOT appear in my unit roster at or in the pack in Scoutbook. When I asked my council about it, they said “an invalid date had been entered” and told me that was the issue. They fixed it, but he still has not appeared. This was in mid-February. When I let them know, my council told me that they don’t have access to Scoutbook and can’t do anything to help me. I am hoping this is the place to get this sorted out. This is getting so frustrating, as we are about to have our last event of the year, and after all of our submitted applications being lost (three times), leader applications still not processed from the fall, and on and on, I’d like to at least wrap up the Scouting year with all of our Scouts on the roster! Thanks!

@ErinBrown The Scout is already in your unit in Scoutbook. The issue is that the Scout is not connected to any of the adult leaders.

Try re-setting your Pack Admin role:

  1. In Scoutbook, go to your Pack Roster page.
  2. Click on your name.
  3. Click on your Pack Admin role.
  4. Click Update to save.

Then you should be able to see the Scout on your Pack Roster.

Correction: There is something else going on.

This Scout is set up as an adult in Scoutbook. I am working on fixing it.

@ErinBrown I have fixed the Scout.

However, I think you will probably need to re-set the Pack Admin roles for any other Admins in your pack.

Edited to add: A Pack Admin will also need to move the Scout into his den in Scoutbook.

1 Like

Thank you so much! You are officially my hero. I’ve updated his connections and added him to his den.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.