BOY SCOUTS OF AMERICA

Scouting Forums

Scoutbook Error Processing Request

I’m on day four of attempting to log in to Scoutbook with fail. I continue to receive the following error:
“Whoops! We encountered an error trying to process your request. Our webmaster has been notified and will fix it ASAP!”
I have cleared all history, cache, cookies etc. I’m in Chrome on a desktop computer. I’m also receiving the same error from my iPhone Safari app.
I am the Committee Chair. Access to Scoutbook is essential. Any suggestions are appreciated!!!

Note: I’ve reported the problem and have an open ticket.

Are you using your my.scouting.org ID and password?

Yes, I am using my user ID and password from my.scouting.org.

Try the forgot password link in Scoutbook. That sometimes resets things. If not, email Scoutbook.support@scouting.org

Thanks, I tried this. I received a new password; however, I still receive the same error.

Similar issue here. Trying to enter rank advancements but receiving an error. Using a Mac and have tried both Safari and Chrome. However, in Chrome, after I select the scout and the type of advancement, the advancement item shows “no data”.

@GregMenegio Look at the scout’s membership. Is there more than one entry in current membership?

No but thanks anyway. Wasn’t limited to a particular scout. Issue seems to have passed though

Unfortunately, my issues continue today.

Did you email support yet?

Yes, I’ve opened a ticket already, but haven’t yet heard back.

What is the SSD number you received in the subject line of one of the automated replies?

The ticket number is SSD-83327

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.