Scouts do not show up to send messages to

We have 35 scouts in our troop but only 19 in the “send messages” list.

  • Parents already have connections with the scouts and the parents have tried the “add a scout to a parent function” - receive error "scout is already connected
  • On occasion scout tries to login and is prompted to add an email address but scouts are then receiving “email address already exists” error

Any other suggestions on how to get scouts setup to receive messages?


Their parents have to invite them to have an account. Leaders cannot do this.

1 Like

Thanks Joe - the parents have attempted this and failed

As @JoeMcKinley noted, only parents can invite the scouts to connect to their Scoutbook accounts. If you can post the BSA IDs (no names or emails) for the scouts who aren’t able to be added, that may help SUAC start diagnosing the issue.

Also, if you have a parent who has been unable to add a scout, if they/you can provide a screenshot of the error message, as well as that parent’s Scoutbook User ID (available in their Scoutbook Edit Profile page) that would also likely be helpful. Ideally, anonymizing the screenshot (e.g. marking out the scout’s name).

That suggests that the scout is trying to enter an email already associated with a parent (for example), or possibly that they already have an account out there for some other reason (e.g. prior Scoutbook account from another council with that email address associated).

The parents already show they have the connections to their scouts - they just cannot send a new “connect to your scout” to generate the invite to the scout to add the scout’s email address. All the connections show up but the scouts are part of of our roster but not in the “send message” function.

This is through our troop’s scoutbook view. Here are two examples

Parent 134711208 / Scout 134711207
Parent 12604891 / Scout 12638734

Scoutbook Tutorial for Parents (SB) - Scoutbook Knowledge Base at bottom of this page there are instructions

Parent Can't Invite Scout to Scoutbook - Scoutbook Knowledge Base - this is troubleshooting

Thanks Donovan - I read these articles and did not know if it applied. The parent/scout connections exist but the scouts are not showing up in the send messages application. So are you saying I need to break the connections for 15 scouts/parents and then reset them?

@AlexanderOrland not sure you did read them - it CLEARLY says the parents need to go to Edit Profile and at the bottom there is an INVITE button - there they can add the Scouts email - at least the first scout has no email so this has not been done

  • Log into your own account on
  • Open ‘My Dashboard.’
  • Click the ‘Child’ under My Family
  • Click on your child’s ‘Edit Profile.’
  • Go to the bottom and click ‘Invite xxx to Connect.’
  • Enter your child’s email address
  • Have your Scout log into their email account and ‘accept’ your invitation and choose a password

@DonovanMcNeil Actually I did read the articles! I had been told by both parents they saw an “update” button. I will reach out to each parent to confirm with the instructions you just sent and see what comes back. I am not in a position to screen share with them but that may be the next step.

Here is the screen shot from another of our scouts/parents having issuesImage 10-22-21 at 3.15 PM

No invite option and the parent/scout are already connected Parent BSA #133061186

yeah that scout is setup - and logged in today within the last 10 minutes - in fact that screenshot is from Scouts Account - see at top it says My Profile

To clarify, there are two different processes here.

  1. Connecting parents to scout’s accounts as parents
  2. Parents inviting scouts to connect to their own scout accounts.

Process #1, ideally, occurs when the scout account is created, and should (again ideally) occur automatically when the scout’s account is created by the registrar. If not, any unit admin can make that connection by executing the steps outlined in Getting a Unit Started in Scoutbook - Scoutbook Knowledge Base. If a parent connection is made in error, only the council (and, I think, the adult who was connected in error) can remove that connection.

Process #2 is must be done manually, by a parent who is already connected to the scout as a parent/guardian. This can only occur if both the parent and scout have accounts and the parent is correctly connected to the scout as a parent. They must log into their account (not their scout’s account). They then follow the steps outlined both in the help article and in @DonovanMcNeil’s post above.

@CharleyHamilton — I might still not be understanding since I think we are going in circles.

  1. We are talking about existing parent/scout/troop relationships - the parents and scouts show up fine
  2. The parents are unable to “invite” their scouts to add the scout’s email addresses (only receive error messages)
  3. Parents cannot manually add the scouts since the relationships already exist
  4. The scouts and relationships show up fine in the troop roster just not in the “send messages” application

Anyone willing to get on a call to chat about this directly?

I do appreciate the effort here - but I am obviously not understanding or not explaining well.

1 Like

Yes - I asked the parent to login to their account and the screenshot is what they are seeing. The scout/parent relationship is fine - but the parent has no way to add an email address into the profile so the troop can leverage the “send message” application.

Your Item #3 is I think where the communication breakdown is occurring. That parents should not be manually adding the scouts, they are inviting the scouts to connect to the scouts’ already existing accounts.

Yeah, I noticed that when I bring up my son’s Edit Profile interface, it now says “My Profile Edit Profile” at the top. I think it used to say “<Scoutname’s> Profile Edit Profile” at the top, but that might be faulty recall on my part. It does still look that way when I navigate to the scout’s Edit Profile via the unit roster.

This is what I see at the bottom of the account page for a “test” scout I created a long time ago for demonstration purposes:

The only time I’ve seen an error that says “email already exists” is when the parent is trying to use their email address for the scout, or when the scout already has another account in the system (to which they have already been invited).

Did you find anything useful on these two @DonovanMcNeil?

Actually, is it possible that the issue is the person trying to send the messages doesn’t have the right connection permissions to some of these scouts, and that’s why some of them aren’t showing up in Send Messages?


Thanks - I and the other Troop leaders have full rights to send messages and I can do all the other edits. This problem is throughout our troop — I have worked with four different parents of the “missing scouts” from the “send message app”. I think @DonovanMcNeil was correct with one of the parents (still waiting to confirm) about needing to press “invite to connect” but I know that is not the case for two of my other problems.

We want to switch to use the “send message” app but cannot if we do not have the 16 other scouts loaded.

It is something specific about the scouts email addresses either not connected correctly with those scouts or the parent/scout invite didn’t process correctly.

How do I escalate for someone to look in the database? I know for scout 12638734 they have an email associated with their account and still do not show up in the “send message” app

I should mention for 12638734 - I watched them login and they were prompted to put in their email address (different from parents) and received a message that the email address already existed. That scout continues to not be listed in the send message app

@AlexanderOrland I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.