BOY SCOUTS OF AMERICA

Scouting Forums

Scouts Missing from Report Builder

Hi Gary,

I am the user that was looking for help in reporting Swimmer Classification with the date and you advised to install the ScoutBook Extension. This worked well, however I am now missing the ability to select two of our 47 Scouts in some report functions. All Scouts appear in the roster and all reports associated with Print Roster functions. I am able to run individual reports for them all as well, but in the selection screens for the larger mass reports, for the Report Builder, I am missing two specific Scouts. Have you seen this happen before? Any suggestions about how to correct this?

to the best of my knowledge, I was not having this problem before installing the ScoutBook Extension. I’m considering uninstalling it to see if these two scouts return to the Report Builder selection screens and reports… this an appropriate next step, or do you have another suggestion?

Thanks in advance for your help,

Chris

Chris,

You can open an incognito window in Chrome or private window in Firefox to test the reports without the extension running. This is much easier than uninstalling it.

There has also been a major change in Report builder ( in scoutbook, not the extension )

Looking to import summer camp MB information and I think that the directions are out of date - in that I do not see a place to select import from “Black Pug as in the directions” the only option I see for importing is the roster import page. I want to make sure that is the correct way before I try to import the camp data.

Blair - is there still an icon in the chrome header that shows the extension ? It should be on the same bar as the menus.

After checking Steve’s suggestion, do you have permissions to see the merit badge quick entry on your dashboard?

Thanks for the tip. Incognito mode was easier than doing the uninstall.

I was able to confirm that the problem I was having with missing two Scouts from report builder reports does NOT apear to be due to the intallation of the extension. However, the problem still exists and 2 scouts are still missing from report builder report selection screens and I don’t know how to proceed. Not good to have incomplete reports. Any advice would be much appreciated. I have opened a ticket with ScoutBook help twice, but have not yet recieved a response…

Chris

@ChristopherSammarco my first guess would be to go to the missing scouts Membership page and make sure the memberships are approved (shows a green check) - if not an admin can approve them

Thanks. Memberships were the first thing that I suspected too, but these two Scouts currently have approved and current memberships. I am a Troop Admin and have even tried to disapprove and then reapprove them…thinking that might work, but no difference. I also have confirmed that I am connected to them both. As expected would be the case as an Admin, am connected to and have full control over all 47 Scouts in the Troop. However, for some reason, these two just do not appear as options on the initial scout selection list for the Report Builder. It’s very odd.

Try this:

Go to your troop roster page.
Click your name.
Click your current pack admin role.
Make sure the position approved box is checked and click update.

Christopher,

Have you tried your report today? There was a change made on June 29, 2019 to fix a permission issue that would cause some Scouts to not appear.

If you are still not seeing all of your Scouts, please send an e-mail to scoutbook.support@scouting.org with the time stamp in the upper left corner of the report and the URL for the report. Post the SSD number you receive in one of the automated replies here. We will have the developers investigate.

Not it. All current positions are marked as approved. Interesting to note that most of my past positions also appear to be approved and still carry the green check mark…

Hi Ed,

The problem with two missing Scouts in my report builder selection screen still persists. I will email Scoutbook Support now as you recommend.

Thanks for the help,

Christopher,

The other thing to check is your connection to these Scouts. Go to My Dashboard -> Administration -> My Account -> My Connections and make sure you have Full Control, Edit Advancement or View Advancement connections to these Scouts.

My point was to click update even if everything looks right. That sometimes resets things. I can’t tell from your comment if you did that or not.

Yes, I did do an update and there’s no change. Thanks for the continued support.

@ChristopherSammarco I have a little time to do a screenshare - maybe we can poke around and see something

Okay, how do we proceed?

ok I will send you a direct message

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.