Too many redirects error when trying to approve rank requirements

I am trying to approve rank requirements in scoutbook which I have done many times. For some reason today I cannot get it to save. I navigate to the scout advancement page, check the requirement and enter a date and click save or click today - the “saving” dialog pops up and spins for about 10 seconds, then the browser puts up an error saying (on chrome): redirected you too many times.


I also tried from an iPhone using safari and get the same error. I also cleared the cookies and that did not help on either chrome or safari.

1 Like

I’m getting the same errors with Edge. And it keeps timing out. I can’t load reports, pull up advancement sheets, or add anything.

Seeing this as well on both Chrome and Edge after clearing cookies

I am getting the same Too Many Redirects when I am logged into my Pack and click on Pack Roster or a Den, so we are unable to see any of the Cub Scouts. I have cleared my cookies. Have also logged into first, then went to Scoutbook. When I did that I fleetingly could see one scout in one den, then got an ERROR LOADING PAGE message.

I have also tried Chrome, Edge, Firefox, and Safari all on different machines and get the same error. I have tried updating scout advancements and run reports. Very frustrating.

Same happening to me as well. Glad I’m not going crazy!

I am getting this error as well. On Chrome, cleared cache, rebooted, and tried again with same errors. First I was using Quick Edit, after several failed attempts I did it again on several single scouts with the same error.

The scoutbook webserver is returning 302 redirects on certain requests on certain actions and then getting stuck in an endless loop of 302 redirects - I am seeing it trying to access the calendar as well as trying to approve rank requirements. Here is an example of a request that starts the 302 redirect endless loop.

GET /mobile/dashboard/calendar/ HTTP/1.1
“Google Chrome”;v=“89”, “Chromium”;v=“89”, “;Not A Brand”;v=“99”
text/html, /; q=0.01
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
gzip, deflate, br
AWSELB=F75FEB9312485C6AE6FAA26E2E48DACF746CAB7729803AD7C0C6D3A43D6D2EE3CF6A548C1FC402CDB64CA16539894EBF29B13E8C9BD5416FBAF4D42FB6EF1A23E4309F2EBE; G_ENABLED_IDPS=google; UserGUID={406E9B4E-CA87-4819-9AB8-285305AECA03}; ScoutbookSessionid={406E9B4E-CA87-4819-9AB8-285305AECA03}; RememberEmail=0; _ga=GA1.2.384631245.1616543028; _gid=GA1.2.23134825.1616543028; Dashboard_Section=Administration; ASPSESSIONIDQAQBDDTQ=LLFCCHNAKNJHAPLGMCDFLMCG; SessionToken=C25E4AF198E04DF0AF4E998149503261FC4DFF8A72BA46619180114901622761; LoginStatus=1; clientTZ=America/New_York; DateLastLogin=3/23/2021 7:01:48 PM

HTTP/1.1 302 Object moved
Cache-Control private
Content-Security-Policy default-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; script-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; style-src * data: ‘unsafe-inline’ ; img-src * data: ;
Content-Type text/html
Date Wed, 24 Mar 2021 00:32:14 GMT
Location /mobile/
Set-Cookie UserGUID={406E9B4E-CA87-4819-9AB8-285305AECA03}; Path=/; HttpOnly; Secure; Expires=Wed, 23 Mar 2022 12:00:00 GMT
Set-Cookie DateLastLogin=3/23/2021 7:32:14 PM; Path=/; HttpOnly; Secure; Expires=Wed, 23 Mar 2022 12:00:00 GMT
Set-Cookie ScoutbookSessionid={406E9B4E-CA87-4819-9AB8-285305AECA03}; Path=/; HttpOnly; Secure; Expires=Wed, 23 Mar 2022 12:00:00 GMT
Strict-Transport-Security max-age=31536000
X-Content-Security-Policy default-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; script-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; style-src * data: ‘unsafe-inline’ ; img-src * data: ;
X-Content-Type-Options nosniff
X-Powered-By Classic ASP
X-WebKit-CSP default-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; script-src * data: ‘unsafe-inline’ ‘unsafe-eval’ ; style-src * data: ‘unsafe-inline’ ; img-src * data: ;
X-Xss-Protection 1
Content-Length 129
Connection keep-alive

There was a database issue. It has been fixed. Users should now be able to login and edit items now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.