Transfer Troops Not working on myscouting

(If you are reporting an issue with My.Scouting, please include all of the following items so we can better assist you:
1) Hardware: Desktop or Mobile (if mobile, please be specific) : MacBook Pro
2) Operating system : OSX-Ventura
3) Browser : Tried both Chrome and Firefox [uptodate]
4) Browser cache has been cleared or you are using a private browsing mode (aka Incognito Window in Chrome) : Yes
5) Member ID & Council of person affected : 12027662 NCAC
Thank you!)

My son’s application transferred to the new troop. However, mine was stuck on “BSA Action Pending”. I withdrew the application, which worked.
Then I tried to initiate another Transfer. But this time, the web page gets stuck on the Search page.
I am able to find the new Troop but when I click “Select” nothing happens. Seem to be a bug in the app flow.

Please help transfer me to the new troop.
Hope to also make you aware of this bug.

are you sure the unit takes adult apps? they have to have them turned on

1 Like

Thank you for the reply.
So, I should contact the new Troop to make sure that their Troop profile in myScouting has that feature turned on?

Is there another process by which that transfer can be done?


Some Councils do not permit adults to register online. You may need to complete a new paper application.

1 Like

Also, I would still classify my experience on the site a bug.
There should be some notice to user, instead of just being unresponsive.


To report a bug, you need to speak with your Council and ask them to open a ticket with BSA IT.


  • and some other words needed just post a “Roger”

@SamuelPark - if they allow online adult apps there is a local unit approval. Also some charter organizations do not allow online adult application

I did called them before posting here. So…