Unable to add Scouts/Adults to Activity

I have previously reported that I could not add people to an event that had been created. I posted about the issue in an Scoutbook bug report and after about a week, the problem went away. Now the problem is back. I now get an “An error occurred while processing the request” message (see below) and I end up having to cancel the entries. However, it accepted my posting the non-Scout participants.

I want to let you know that while I am committed to making Scoutbook work, the Scoutmaster and other adult leaders in my troop are getting increasingly frustrated with Scoutbook and IA2 because of the constant stream of problems that seem to take place every time the development team tinkers with the programs. They are just about ready to direct me to stop using both Scoutbook and IA2 and are already instructing the Scouts to rely exclusively on paper records They feel that in the rush to add new features, many of which only are useful to district commissioners and the Council, you are destroying the usefulness of Scoutbook to unit leaders.

Yours in Scouting,

Chuck Olson

OA Representative Advisor & Registrar

Troop 463, Sandy Springs, GA
770.851.0418

Chuck
The programmers are looking into your issue. I sent you a personal message. Click on your icon in the upper right and the envelope.

Bill: Any update on when this issue might be fixed? I tried to add Scouts to two recent events and it errored out again.

This has been shown to be the best solution: IA Error Message - #3 by JenniferOlinger

So delete the existing activities and start over the way Jennifer suggests?

She says that works best!

Ron: That solved the immediate problem.

Chuck

Not to raise a topic from the dead, but the problem persists so it never died in the first place and I wholeheartedly share the frustration of @CharlesOlson.

Define your problem. It isn’t clear if your current problem is adding adults or deleting activities or what. What error are you seeing on what screen?

@Matt.Johnson I did not go into detail intentionally, instead choosing to reference the original reported problem as the explanation as it was sufficient in my eyes and I had no desire to create a separate topic of conversation within an existing thread.

As you requested, the full explanation: If I enter an activity using either method (a) create an activity and add participants or (b) going through the roster and checking the participants and then creating an activity, all is well. If I subsequently return to the activity to edit participants, regardless of how the activity was first created, I get an error and it will not let me add participants (save the changes). I can remove all participants and delete the activity. Don’t know if I can remove one or two participants and save it. Don’t know whether it only lets me add adults or non-registered participants and save it. The only solution I have is to create the activity and get every participant correct the first time; otherwise, I have to delete it and try again for perfection.

Don’t read too much into the server error warning as it only appeared once or twice during yesterday’s fun along with the Whoops error whereas all times prior (throughout 2021) and this morning I was greeted with only the Whoops error.

1 Like