Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Unable to add Unit Service hours

I am unable to add service hours. I tried last night and again today, when I get to submit the hours and it throws a JSON Error. I also tried to go to the Submit a ticket link on the Scoutbook website and it gives me a 404 error. Has anyone else experience this?

Error: Error validationg JSON. Error: - Invalid type Null, expected integer for userId (org.mule.module.apikit.exception.BadRequestException)

Unit-level volunteers, parents and scouts are no longer allowed to submit support requests directly. We’re supposed to either reach out for assistance here, if it’s something that SUAC or other volunteers can help resolve, or reach out through our council, which theoretically has a designated way to contact support.

This is a known issue, which I believe has been reported to the developers. I don’t recall whether or not it’s been fixed. I think that the last time I checked, I still couldn’t enter non-integer durations for service. I’ll find out again soon, since we have a service project coming up in a couple of weeks where we will likely have a variety of different service durations.

There are a variety of threads on this topic that come up when you search JSON error, which can probably give you a better backgrounder on the subject that I can. Short form: the implementation was intentionally as an integer rather than a float for backward compatibility reasons. I don’t agree with the rationale, but that’s what was put forward.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.