Unable to connect Scout with MB Counselor

Keep in mind that there are often many threads where the same issue is discussed, so not all of them necessarily get notification when a fix gets posted. The most reliable way to get notification about bug fixes is to subscribe to the change logs, as described in the post here: Change a profile picture - #26 by CharleyHamilton

I have had this happen as well and find as a MBC I was able to connect the scout on my end.

Just reporting another SM having the same issue - cannot make any connections to MB counselors, including active counselors in my own troop who I had been connecting a few weeks ago.
thanks for solving this issue

I am also having this issue. I have successfully connected this same MBC to another scout in January but now I cannot connect to this second scout. I have entered the MBCs full name, BSA #, email, city and state and it says the MBC is not found even though they show up on the list of MBCs. I have already gone to update my SM and Unit Admin positions.

After several hours of trying various combinations, I am also unable to connect to sent the merit badge counselor the scouts name, member Id # and which merit badge. They were able to connect with the scouts. I even tried my own user name, and it could not find me as an MBC.

This is a known bug. It has been reported to the developers.

Same problem here, can’t add a mb counselor to a scout

That worked! Good idea!

I still can’t connect him to his son, but now he’s connected to both daughters!

1 Like


In principle, with the son’s name, BSA ID and DOB, the dad should be able to connect himself to his son. The parent needs to log into his own Scoutbook account, navigate to

My Dashboard → Administration → My Account → My Connections

They should see this at the top:

When they click on the circled section, it should bring up this interface:

1 Like

Thanks @CharleyHamilton

1 Like

We are also facing a similar situation. Basically, the whole search functionality for connecting the MB counselor to the scout in scoutbook is broken. I (Committee Chair) and our scoutmaster tried different names who are MB counselor and none of them come up when we are trying to connect the scout to MB. However, all these MB counselors can be seen on the troop dashboard where it says " MB Counselor List". It says “No record found that satisfies the search criteria” and we running the search with “Include MBC Only”.

Any help or a fix would be greatly appreciated. Thanks!

The search being broken is a known issue that SUAC has reported to the developers. The BSA does not specify when a fix will be released. In the interim, one approach to making the connections is actually to have the MBC make the connection from their end, as described in @JenniferOlinger’s post above.

Thank you so much for directing me in the right direction. Appreciate it.

1 Like

I am also having this issue. Search is broken for both finding MB counselors and searching for existing leaders that I know are in ScoutBook.
Hopefully support fixes this soon, as the broken search function blocks a lot of functionality in ScoutBook.

This is a known issue. The developers are working on it. The current workaround is to have the MBC connect to the Scout via the MBC’s connection page. They need the Scout’s BSA Member ID and last name to do this.

Thank you, I can try that workaround for MB counselors, but it still leaves me with no way to add an existing leader to a unit.

It appears the bug has been fixed! The search function for MB Counselor just worked for me.

Has anyone had issues connecting with a Scout who is registered beyond the age of eligibility? Tried to connect on my end (MBC)- said Scout was not found although I have their ID, last name and DOB. Tried on their end and I don’t show up.

If you post the scout’s BSA Member ID and yours (no names please!), the SUAC folks might be able to look to see if there are any “behind the scenes” issues that might be impacting the connection attempt.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.