Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Unable to Login to Internet Advancement

I can’t login to Internet Advancement. I’m using my Google Login. I can login to everything else. It allows to me to click on Google Login and pick my account. It then goes back to Login page. I have even cleared my cache to see if that helped. I am listed as the Unit Admin. , Key3 Delegate, and Unit Advancement Chair.

Have you tried using a private / incognito window?

Just tried that. It won’t let me login to anything scout related. This just started today. I had no issues with it Wednesday evening.

I can report the same issue. I’m able to access scout book with my Google login but when I try to switch to internet advancement it takes be to the login page, and using Google again just results in another login page.

Tried accessing from scout book and from my.scouting , Same results

I’m having the same issue. Furthermore I couldn’t switch back to using BSA credentials instead of Google on my.scouting.org. When I try that it thinks the username field is empty but it’s not - it’s filled but disabled.

I was able to switch back to BSA credentials and that did fix it for me, I can now login to IA and SB , but that’s kind of a bummer.

I just switched back my BSA credentials and that works.

My problem is that my old BSA username is apparently only 7 characters and it has to be 8, but the edit field is disabled so I can’t change it. So I can’t log in to Internet Advancement to enter camping nights with my Google credentials, and I can’t switch to BSA credentials!