Unable to update adventure requirements for cub scout but still able to add merit badge for boy scout

I am unable to update the Protect Yourself Rules (Wolf) for my cub scout using Scoutbook, however, my other two scouts I am able to use the app to submit merit badge information. It says to try again later but this has been going each time I check for almost 2 weeks.

@MichaelShea3 Is the cub in a den?

I found your cub @MichaelShea3 and there was some funny stuff with your connection - I believe I fixed it for you

It is for a Cub scout, yes.

@DonovanMcNeil was asking about whether the scout was assigned to a den in Scoutbook. That’s how the database decides what adventures/awards are available to earn. In the end that appears not to have been the issue (or maybe not the only issue). However, it’s one of the most common problems.

1 Like

Thank you for looking into this! I appreciate it. I just reopened the app and I am still getting the same error.

@MichaelShea3 try again - maybe quitting app all the way first - or a log out

I’ve completely closed the app twice and reopened. I am still getting the rror.

At least on my device, closing the app doesn’t necessarily actually kill it. I have to manually go in and kill it to ensure any glitches are resolved. Or, wait until I restart my device. :^) That might be an Android thing, though. I’m not an iPerson.

1 Like

Each time I reopen the app it asks me to log in. I also just turned off and back on my phone. Still have the same problem.

Are you able to add advancements for your son at https://scoutbook.scouting.org?

1 Like

I have been able to use the app in the past, and can use the app for the older boy scouts - it just doesn’t work for the cub scout.

I do not see where to add advancements for my cub scout on scoutbook.scouting.org. I see links for:
My Dashboard
my.scouting Home page
my.scouting dashboard trainign
change log
legacy forums

  • no where to view or add my scouts.

Have you fully logged out with clear data in App?

Click My Dashboard

I logged out and it completely cleared my username and password form the app. I logged in again - same problem.

I’ve now completely deleted the app and reinstalled it. Still get the same problem. @DonovanMcNeil

Click my dashboard > administration > scout name > scouts advancement > rank > adventure name > individual requirements.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.