Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Unable to Upload Advancement Data

I have been advancement chair in our troop since October 1, 2000. I am Woodbadge trained, with two staff experiences. I am an Eagle Scout. My son is an Eagle Scout. I have worked with over 50 Eagle scouts in our troop in my tenure as Advancement Chair. I am a vigil honor member of our OA Lodge. I am on the council executive board, and I have served as district training chair, district chair and council training chair. So why do I feel like quitting?

Understand, my daughter, who worked 5 years at the local council camp calls me one of “those scoutmasters.” I do not tolerate a lot of nonsense, but my scouting experience has helped me with that. With this in mind, and recalling the Woodbadge adage that, “Feedback is a gift,” here is my problem.

I am listed as advancement chair, and Key three delegate in Security Manager. I have never had problems uploading advancement information since we switched over to Internet Advancement 2.0. Now, when I go in to upload advancements, my upload file button is grayed out. I searched and found people who had similar problems, but never ones who had been advancement chair for a long period of time.

In the grand scheme of things, I do not have the patience to sort through forums to find answers that can be answered with a simple telephone call. Creating a “ticket” in any support environment has never been a pleasant task. “Our IT manager is Helen Waite. If you have an IT problem, go to Hellen Waite.”

As a volunteer, do I have the right to expect more?

Can I get my problem fixed without resigning and letting the next advancement chair deal with it?

YIS
Mark

1 Like

In IA2, under the BSA fleur de lis logo in the upper right corner, which position is checked? If I’m in “parent” mode or “ASM” mode, I can’t update advancement. If I’m in “Key 3 Delegate” mode, everything works fine.

1 Like

The position checked is “Unit Advancement Chair.” It is my only option, since my son is now 31, and no longer in the troop.

Well nuts. Another perfect plan fouled up by the facts. :^)

Do you see different behavior on different browsers?

ETA: Hang on…it doesn’t offer you “Key 3 Delegate” as an option? How long have you been listed as a K3D? It seems like you should be able to upload as UAC, but I would expect it to offer the K3D option as well.. Nevermind. Looks like you got there at the same time I did. That said, it should still offer you the upload option as UAC.

So, I was wrong. I had as an option, “Key 3 Delegate” and “Unit Advancement Chair.” When I selected Key 3 Delegate, I can now upload the advancement file. Very counter-intuitive. So, I can now do what I need to do, but it just seems weird that I have to upload the date as Key 3 Delegate, and not as Advancement Chair.

1 Like

that does not make sense, though I am glad for the fix for you - what is your user name and I will have DEV look at it

I wonder if it is because you have both MYST positions?