Unable to view Merit Badges in Scout Book

I have a problem with two of my scouts in Scout Book. When I attempt to view their progress on partial merit badges or view completed merit badges, I get bounced back to My Dashboard. I do not have this problem with any of my other scouts.

I can add completed requirements for both of these scouts using the Quick Entry feature.

I can see (and verify) what they have completed by running the “Merit Badge in Progress” report.

Our troop is going to transition away from Troop Master, but will not do that until we get this issue solved.


Check their membership. I’d guess they also have a membership in a pack, and it’s confusing Scoutbook.

1 Like

Like Jacob said, you have 2 Scouts with open pack memberships.

In Scoutbook, go to each [Scout]'s Membership page, click on their pack membership, and add a date ended.

You also have a Scout (initials C.M.) with 2 troop memberships. You can end one of them.

@GregKropp - did you check the active membership

It was the membership in the pack and troop. When I ended their pack memberships, everything worked.

Thank you


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.