Version Change Failed. Incomplete user requirements for the selected version

I’m trying to change one of my AOL den members to the 2024 version of the rank requirements, but it gives the above error. I was able to switch all of the other members of the den to the 2024 requirements (why wasn’t this the default in the first place?), but this one Scout gives the error. This is also the only scout in this den that I added adventure signoffs via the bulk advancement entry.

I am also having the same problem. Any resolution?

this is part of a reported bug - watch the change log for a fix

I have a Scout that was on the 2024 requirements and I changed to the 2022 requirements to review an advancement and now it won’t change back. Same bug?

@TWms no - what do you mean it wont change back?

When I click on the 2024 requirements, it gives me the error mentioned by the OP. It won’t change back to the 2024 requirements even though it was set to the 2024 requirements previously.

3 Days ago I asked staff and they said part of same bug

I am having the same issue. It is for my child. I had him in the AOL 2024 requirements, changed him to the 2022 with the intent to change him back to 2024 requirements immediately, but I keep get the same error message.

SB User ID: 10157476

BSA Member ID: 13366803

If you switch Rank versions and move too fast and do not let the change fully load it messes things up

1 Like

I’m trying to add electives to my den but this is what keeps showing up

I’m getting this error too!
I tried clearing my history and cookies… didn’t have any affect… still getting “This advancement has no requirements” error message. On the upside, the requirements I enter through the bulk edit still seem to be getting recorded. I can see the adventures as complete in the regular Scoutbook side. I am only seeing it on 3 of my AOL scouts.

@YorvskaSalazar I just reported this issue to the developers a couple hours ago.

1 Like

Thank you! I was able to use the bulk entry after reading through this thread.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.