BOY SCOUTS OF AMERICA

Scouting Forums

Can't enter rank advancements

First time user to IA. I am the Scoutmaster for our troop, and due to recent personnel changes at our troop, I’ve been tasked with handling the advancement recording until the end of the year. I was able to login in okay, and was able to record the merit badges. However, whenever I try to enter the rank advancements I get an error. Is there a secret to rank advancements that differs from MB entries?
Also, we do not use Scoutbook.

Thanks in advance!

I’m also having the same issue with rank advancement and I am the Advancement Chair. What is the solution to this issue?

I am not seeing this happen - perhaps me setting up a screenshare to isolate it might help

I was contacted by a volunteer this morning that is having the exact same issue. trying to enter a life rank and getting the error “user rank record update failed.” I also went in and tried to do it and got the same error.

OK this failed for me and I captured the data for it - sending to Developer

1 Like

I’m having the same problem. (Troop 55 committee chair)

I am having difficulty entering Rank Advancements. I have tried Firefox, Google Chrome, and Internet Explorer. I continue to get and error message that just says error. i have also tried to hold the shift button and refresh my page and i continue to get error messages when i try to enter Rank Advancements. What do i need to do to correct this problem?
Thanks for all you do!

I’ve been having the same issue here - both yesterday and again today.

Do you know who we can email the information too so they can imput these rank advancements for us. I have been working on this for an hour now. Truly wish i could speak to a person.

1 Like

I have no idea. Same here. I was hoping they would have a ‘live chat’ option available, but I don not see that.

who can i email my Rank Advancements too for the them to be entered? I have been trying to enter them for over an hour now. I have tried Firefox, Google Chrome, and Internet Explorer, I have also tried holding the Shift button and refreshing the page. I continue to get errors saying “User Rank record update failed” and “Please provide user value for [”/0/userld"].

IA is broken for ranks right now - you can use scoutbook.com or take them to your council for them to enter them

It would be so helpful to actually be able to speak to a live person for sure. This is becoming very frustrating. I am not very savy with technology, and could really use some help. LOL

1 Like

Kimberly,

This is nothing you are doing wrong. There is a bug in IA causing the issue.

I’m having the same problem not being able to put in our scouts ranks and our council wont send the ranks until I can approve they have earned them very frustrating. My scouts have worked hard on getting these ranks and I can’t give them on what they have earned. This issue needs to be fixed quickly PLEASE

Manually fill this out to get ranks at shop if needed

If you need the ranks ASAP, you can use Scoutbook.com to add and approve them until the Internet Advancement bug is fixed.

@DonovanMcNeil any word of when the issue will be fixed?

It is being worked on - we do not know when it well be fixed

1 Like

Ok, thank you @DonovanMcNeil