Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Internet Advancement : New Domain for Scoutbook

I must say I am very disappointed with the way transition to Internet advancement happened. Just cannot do anything and constantly getting an unexplainable error and message “It seems we are experiencing temporary issues with our servers. Would you like to switch to Offline Mode and synchronize your changes later?”

Report module is not working and not able to execute troop recognition report being advancement chair. There is NO phone to to talk to anyone to see if issues can be resolved. I have to plan for CoH and doing everything now manually. Very very disappointed.

4 Likes

Have you tried opening a private or incognito window?

Are you using the new url for Internet Advancement?

https://advancements.scouting.org/

I would like to give this comment a strong second. As the advancement chair of our troop, I have always used scoutbook.com and whenever I try to use scoutbook.org, it doesn’t let me do anything (put in service hours, create a purchase order, and a merit badge). Why was scoutbook.com shut down before the bugs were worked out with scoutbook.org? If I can’t get access these things and there is nobody to help or train us, I will no longer be able to serve as advancement chair.

2 Likes

@KerryRyan1 - just to be clear on this domain naming thing. The scoutbook.com core was moved to a new domain scoutbook.scouting.org which I have no issues accessing and using. There is no scoutbook.org domain that I can readily tell. The is also Internet Advancement which resides in advancements.scouting.org and I have no issues there. The core system of scoutbook has not changed in the move to a new domain… I looks and works just like it had 25 hours ago. So I am not really certain what your issues are as it just points out dissatisfaction rather than specific issues or errors.

1 Like

@KerryRyan1 Scoutbook and Internet Advancement were recently moved to a new domain. The new urls are:

Scoutbook:
http://scoutbook.scouting.org/

Internet Advancement 2.0:
http://advancements.scouting.org/

1 Like

I know it is very disappointing. I know BSA is trying to cut costs, but a national support phone number should not have been removed.

2 Likes

In the new format/version/domain, I can’t put or approve service hours or merit badges and can’t create a purchase order (or find a history of purchase orders). I really cant do anything at all (even though I’m listed as an admin). I’ve been doing all these things in the Scoutbook.com version. Can anyone point me to a step-by-step training or tech support?

I am using following domain. Someone needs to quickly solve have a telephone line open to talk to someone or open previous domain again.

1 Like

@AbhineetKothari Are you using a private / incognito window?

Use an incognito or private window and go directly to scoutbook.scouting.org

No functionality has changed.

Here are specific issues -

  1. Unexplainable error after login on first screen
  2. I have tried multiple ways but no mechanism to pull troop recognition report for a particular date range
  3. Pop-up message server issues asking to work offline mode. Even if you choose nothing happens…
  4. Not able to approve scouts service, hiking, and camping hours. keep on getting errors but no error description. Don’t know where to go.

I have not been able to move forward with above errors. Please see screen shots.

I was so happy with scoutbook earlier version.

Scoutbook Errors.docx (476.8 KB)

1 Like

@AbhineetKothari - those errors you haev posted are from advancements.scouting.org and not scoutbook.scouting.org. The advancements.scouting.org domain is known as Internet Advancement and scoutbook.scouting.org is by its name scoutbook itself.

Thank you Jennifer for the private/incognito window suggestion. It’s working and I am very pleased to see old scoutbook screen. Thank you so much.

1 Like

Did you get a chance to see the word document I attached? You will see those errors are from scoutbook.scouting.org page. I am NOT logging into advancement at all. Anyway, I am able to access now thru incognito window and it has solved the problem as I can see previous scoutbook screens. Hopefully, in next few days all of these bugs/problems will be resolved.

@AbhineetKothari - why yes I did hence my post as your grabs clearly state Internet Advancement.

user_error

Thank you jacobfetzer… incognito window solved the problem.

Thank you Stephen. Please see the address URL and clearly indicates scoutbook.scouting.org I don’t know if it is taking me to internet advancement…

@AbhineetKothari You need to clear your browser cache and cookies.

Thank you Jennifer for all your help. Yes, I will clear the browser cache and cookies. Thank so much for your time today… greatly appreciated.

1 Like

@Stephen_Hornak, imho, as a “leader” you should not be so condescending to those needing help… especially when you are clearly wrong. I’m glad @AbhineetKothari was able to get help from someone who is helpful, friendly, courteous, and kind.

1 Like