BOY SCOUTS OF AMERICA

Scouting Forums

Can't Run historyt reports - SSO message keeps coming up

Whenever I try to run an advancement history report for an individual scout I get a new tab with this message:

Single Sign On (SSO) is required to run reports. Please login to Scoutbook with your Scoutbook email address, then use the “Switch SSO Profile” option on your Profile page and enter your Scouting.org (my.Scouting) UserName and Password.

I’ve done this process dozens of times. Logged out. logged back in. switched sso profile. get the “my.scouting account likes successfully” message . Still can’t run report.
I am the advancement chair

Scott,

Are you using Scoutbook or Internet Advancement?

Same thing happened to me last week, and still happens this week if I am logged in through Scoutbook. (Our troop does not use Scoutbook, so that’s why I am doing our advancement reporting and running reports in IA2.0.) However, I found that if I log in through my.scouting.org > Legacy Tools menu > Internet Advancement 2.0, I can run reports and no longer get the SSO message. Try that if you’re still having problems–I hope it helps.

@ScottKruger & @DarcyKendall - trying to figure this out as I cannot reproduce it. What are each of your positions in the effected unit?

I’m a Unit Advancement Chair. You can see my previous thread below: “Can’t download a previous Advancement Report.” I was happy to be able to finally get the report with the help of Stephen Hornak. As I recall, he thought it might be caused by a background sync problem, and since I’m not a programmer, I don’t know any more than that. Your original poster on this thread didn’t come back, so maybe he was able to download the file eventually.

@DarcyKendall so you a designated a Unit Advancement Chair in My.Scouting Unit Security Manager?

Yes, our Committee Chair designated me as a Unit Advancement Chair in the Security Manager.

I am also designated Unit Advancement Chair.

After multiple tries I was able to generate a report. But then could not repeat it. The system seems to not remember that I did the SSO thing. I’m using MS Edge in Windows 10.

OK Edge is a clue too

Hi, @ScottKruger,

I know that there used to be issues with Scoutbook running correctly in Edge. Have you tried another browser?
ETA: Ninjaed by @DonovanMcNeil this time.

@DarcyKendall what browser were you on?

Can’t. I’m accessing from work and Edge is the only one installed. Need IT permission to install another.

SSO relies on cookies to work properly. If you are using a work computer, it could be your IT has restricted how cookies are used.

HOWEVER - I just logged on by going to scoutbook.scouting.org, logging in there, then going to IA 2.0 and am now able to run history reports and unit roster. So it looks good right now…
Before I was shortcutting to IA 2.0

Last night, Firefox 67.0.4 on macOS 10.14.3. Did not try Safari last night. Last week, had the same problem with both browsers. See previous thread for more detail.

@DarcyKendall - has the problem returned ?

Yes, I got the SSO message again last night when I first logged in through Scoutbook and tried to download the report of the advancement records I had just input, so I just logged out and then logged in to my.scouting.org > Legacy Tools and was able to download the report. All on the Firefox browser; did not try Safari.

@DarcyKendall - as I recall you were not using scoutbook for your unit unless that changed. So with that in mind you should just go to the scoutbook.scouting.org site for advancement. The SSO public/private key-token thing gets a bit jacked up flipping back and forth. This is why there is warning text about it.

Right, we are not using Scoutbook, and yes, I did start with scoutbook.scouting.org last night. That’s when I got the SSO message. I will try it again tomorrow and see what happens.