Eagle Application printing problems

The Eagle Application printing from Scoutbook in the Merit Badges it is listing a hardcoded Citizenship in Society and also adding Citizenship in Society a second time. You would think since July 1st was the date for 8-9 months this oversite wouldn’t have happened. This scout has 20 completed merit badges 13 Eagle Required, 7 Non Eagle and still working on Citizenship in Society. Note the error when printing.

It is missing the most important Merit Badge his “Finger Printing” which was his first non Eagle and second one listed besides Swimming. Earned 8/5/16.

@JDeMeritt what is BSA number?

or better yet - @JDeMeritt - what is URL of report?

It should be a problem on all Scouts I actually tried to run it on a scale that earned a few merit badges at summer camp thinking it might be a good way to present and we have in the past their eagle application at tenderfoot just to show them what it looks like and give them an incentive. His BSA Member ID:13889087
I’m not sure I can provide a URL considering the form downloads on to a PC and I’m sitting on a phone right now but this is what I was able to copy https://reportspd.scouting.org/advancements/webscript/output/sbreports.aspx?Method=ExecuteScriptSet&ScriptSetCode=SBEagleScoutRankApplication&ScriptCode=ProcessPrintEditablePDF&UserID=674016&UnitID=20908&Version=&MemberID=&LastName=

yeah I was finally able to reproduce it and have reported it. Let me look at fingerprinting for this scout

that is the right URL

There are fixes for both issues being pushed sometime this afternoon

@JDeMeritt this should be live now - would help if you could check by re-running the Eagle App again

I ran it on the scout in question and another Life Scout it works as expected. I did however run it on the tenderfoot scout it still created the extra MB line. While I understand it isn’t going to be turned in for a tenderfoot scout it still should not be pulled on the app anymore as it is hardcoded.
BSA Member ID:137222930


Thanks. I have notified the developes.

1 Like


Can you try again? Another fix was pushed to remove CIS from the list of optional MBs.

1 Like

This scout listed above has 5 merit badges earned. E-Science, Swimming, Mammal Study, Fingerprinting & Pulp and Paper. Only the two Eagles E-Science & Swimming & the one non Eagle Pulp & Paper are on the application. Both Mammal Study & Fingerprinting did not show up.

To be fair the other 2 merit badges weren’t listed on the previous screen print I just saw the duplicate of the Cit. in Society line and didn’t notice the others weren’t there, thanks.


Are all 5 MBs approved in Scoutbook?

yes they are @edavignon

1 Like

@JDeMeritt try running it again = they found the issue with MBs

This looks good now tested on a few scouts and works as expected. Was the problem with that scout or just how MBs are sorted, thanks.

How MBs were looked up by the program

Ok thanks for getting corrected so quickly.

2 posts were split to a new topic: Unit Missing from Eagle Application Merit Badges