IA activity and report error? No data


When I try to add an activity in IA and click to “add person” there is no data, but another leader in our unit was able to do so.

Also, from the roster page. When I “run reports” and select “activities summary report” for all time periods (or any time periods) it does NOT generate a report. BUT I am able to follow this path and run advancement reports for any time period.

Can anyone help?

At the risk of sounding like I’m suggesting “restart your computer”, have you tried a hard refresh of IA (Ctrl+refresh) to force a reload of the page? Sometimes, there are things that get cached which break things behind the scenes.

@CharleyHamilton any suggestion is okay with me. I tried that and deleted all browsing data. No luck using chrome or edge. Other ideas?

@CharleyHamilton I will also add I’m a CM and the data is there for the pack, but this problem is only for my ASM role in the troop…strange.

I think it is probably a permissions issue. The position of Assistant Scoutmaster probably does not have automatic access to reports.

@JenniferOlinger this doesn’t make sense to me. Why would couldn’t an ASM be able to add an event or see how many camping nights a scout has?

@RichardFriesner Individual units can decide who they want to grant access to. Some units want to limit who can update their calendars.

@JenniferOlinger I think I understand what you are saying via the functional positions, but I’m an ASM and Training Chair for the troop. It doesn’t make sense that I wouldn’t be able to add an activity in IA…does it?

Is there a way to check my status and issue here?

Here is the “no data” error

Here is the report error…it just spins without any output.

I’m an ASM as well, but I’m also a Key 3 Delegate, so that throws off my ability to test the “just an ASM” case.

Based on the abilities matrix here, however, it seems like you should at least be able to enter activities in the logs:

It would seem odd not to be able to run the report if you have access to enter and approve activities as described in the help wiki above.

Are there any scouts in the troop to whom you don’t have a connection (e.g. new scouts)? ASMs don’t (automatically) get connected to all of the scouts in the unit. Maybe that’s what’s causing the issue with both reporting and adding folks to the new activity?

It’s a relatively big unit…is there a way to check if I’m missing a connection without clicking on each scout’s profile?

Someone who has access to the Connections Manager (Unit Key 3, Key 3 Delegates, Scoutbook Unit Admins) in Scoutbook can locate your name and “scroll across” to see if there are any blank spots, then add those connections. They could also just reset your permissions using the same tool to whatever the unit’s desired access level is for ASMs and see if that fixes things.

It looks like with the change to Scoutbook Plus Internet Advancement the functionality is limited to Key 3 and Key 3 Delegates. I could do it as COR, and an ASM could not. I assigned her to Key 3 delegate and then she gained back the functionality. Don’t know if this was intentional or a bug.

How do I get in touch with the advancements.scouting.org developers? This problem is not getting resolved.

Thank you,

@edavignon are you able to help here? My thanks, Rich

You only have two options. Work it here where the team of volunteers help you gather the data they can feed back to the developers OR have your council enter a ticket and work it with your council. No direct access to the developers is possible.

1 Like

@CharleyHamilton I was able to go through and check this. I have all the scouts in the troop as a connection in scoutbook, but the problem still persists where I cannot create events in IA or run the activities reports…any other ideas what’s going on?

@RichardFriesner - do you have unit admin listed as a position in scoutbook?

1 Like

@Stephen_Hornak yes I think so.