Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

IA2 Calendar Bugs: Activity Logs

  1. Calendar reverts to the Current month on the end date. If I just entered an event that was several months back in the Activity Starts box, the Activity Ends box should default to the same month I entered in Activity Starts.

  2. Keyboard Entry: When using keyboard entry for a date (rather than pickling it from the calendar) the format is not a standard date format, as it requires both spaces and forward slashes to register in IA2 as a date. I should not need to include spaces in a date, as spaces are not part of any standard date format.

Looks like there are a few more items in Activity Logs that I don’t think are working correctly:

  • When a campout has been approved, the relevant date is the campout date, not the approval date. Please display the Campout Start Date in the list, rather than the approved date.

  • When an adult enters activities, I don’t believe that Key 3 approval should be required. (Maybe that is just me as a Key 3 being jealous of my own time …)

  • When the Adult activities are being approved, the summary interface on the left says “Approve x activities for 1 youth.” I feel young, but not that young (especially not after sleeping on the ground at a campout) …

  • It looks like the default behavior for personal campout entry is to select All Day Event. I experienced a few events that jumped back one calendar day from the dates I selected. I am in Mountain Time Zone so I don’t know whether this is due to time zone, Daylight Saving Time, or what

  • Based on the date jumping above, I have a campout that now has the wrong date recorded. As I have already approved it, it seems to be locked. How can I delete or edit approved items? (This is in my own adult log)

A few more issues:

  • Go to Scout profile page, then drill into Camping activity log. Scout has several campouts recorded. Clicked APPROVE ALL at top of page, then got an Approve Advancements page(?) (Remember these are CAMPOUTS)

  • Should I have the ability to input or change dates on this, or are the dates a product that the module called was advancements, not Camping or Activities?

  • Clicked APPROVE AND FINISH at the bottom, and it gives an ugly error message

  • It looks like the items that blew up in the list of activities are not in my approval roster anymore, and now I need to approve them 1 at a time from the Scout’s Camping Activity list. This gets really messy really quickly …

Not to be rude or anything, and acknowledging the plan for an updated programming language, etc. and all that but as a Scouting volunteer, I sure am eating a lot of dog food right now when just a few weeks ago we had a system that was working. Not a fan of the Minimum Viable Product in its current state at this time … not really viable in my opinion.

1 Like

Agreed. We haven’t been camping, but I have basically stopped all use and waiting for bugs and features to be added.

I have been trying, unsuccessfully, to change the location for one of our Hiking events. Originally it was going to be a trek at Philmont. With Philmont closed, the crew has switched to a five day trek on the Appalachian Trail. IA2 will let me change the dates, but every time I change the location to the Appalachian Trail, delete the address for Philmont and change the state to Tennessee, when I save the event, IA2 puts Philmont back as the location, with Philmont’s address. I would delete it and start over, but since that is another bug that is waiting on a fix, why will it not let me change the location?

on change location @CharlesOlson it worked for me - took some time and I had to reload page to see it

Interesting. I tried it four times and it reverted back every time.

Any word on when we will be able to delete cancelled activities?

no on delete - I did try a past even not future so that might be a difference

Is this the last “big” item that we need fixed? Are all the other “big hitters” done?

Donovan:

I gave it rest, grabbed some lunch and then tried again. It still will not let me change the location.

Matt:

By no means is this a “big” item, but if we don’t report issues as we find them, then the developers don’t know there are things that need fixing. Sometimes, when they are working on one of the “big hitters”, they are able to fix one of these small ticket items because its on the “to do” list.

Chuck

@CharlesOlson i tested this on a future event and it worked fine for me - if you want I can setup a screenshare to look at it

OK I reproduced this now and I will report it

Thank you, sir. Hope you and yours are well.