Non-Registered Parents Now Showing As Registered Leaders in Internet Advancement

I just went to enter community service hours in Internet Advancement. Why are non-registered (but Scoutbook linked) parents now showing as registered adults when you go to select participants for events?

What makes you think they are registered leaders?? They are just parents - a unit needs them there to record properly if they attended

When you create an activity log, previously it only showed registered adults. Now it is showing non-registered adults as well. When you select those people it lists them in the event as “Registered Adults”.

Oh I see - OK let me send that in

1 Like

I’ve got another question. Can I just add here? We have activity logs that are still showing as pending approval. Who has permission to enter logs, without requiring approval? All the logs were entered by a unit admin. Our Committee Chair took a look and she is able to approve, but says it looks like she has to go to each Scouts log and approve each individual entry.

If it needs approval - all should show under Pending Items

Yes, it does. Previously, as a unit admin, the entries would not show as pending approval. They would automatically be approved when a unit admin entered them. Since fall, entries entered have showed as pending approval. Our Committee Chair says the only was she sees to approve them is to go to each scouts individual log (as opposed to being able to approve an entry for the activity as a whole- such as a unit campout or unit service hours).

Also, are there only certain positions that can approve entries?

They are auto approved - so would need to learn more

So as a unit admin entering the logs, they should be auto approved?

@CarissaKrater yes as long as the admin position is good

I am a unit admin in three units. Any activity logs I have entered since fall is listed as pending approval.

Go to Scoutbook (not IA) > Go to unit Roster > Click your name > click Admin > click Update - that should solve it - in each unit

So I am clicking the admin position in Scoutbook and then clicking update?

ETA - From Scoutbook, I clicked on the unit - Pack/Troop Roster - my name - Pack/Troop Admin - then update. It doesn’t seem to have worked. I cannot approve entries I previously entered.

Yeah - I forgot SB Admin is messed up in IA currently - it is being worked on

So is the only way for the activity to be approved is by the Committee Chair? Is the only way for her to approve to go to each Scout and approve each individual item? Is there a way for her to approve the activity as a whole?

Well IA was first built to look at real memberships first - So CC or unit leader, or Key 3 D should all work fine. (Unit Admin should too but something happened)

Key 3 (Unit Leader, Committee Chair, or Chartered Org. Rep.).

Or the following can be designated at my.scouting (Roster → Position Manager → Functional Roles):
Key 3 Delegate
Unit Advancement Chair

Just want to make sure I am understanding correctly.

Unit Admins should have their activity logs automatically approved, but that is currently not working properly. For the time being, only the Key 3 can approve (or designees).

I have the opposite problem. A previously registered leader has been dropped from Scoutbook. I’m one of the unit administrators and I tried to add her back with name, email address and BSA #. The system can’t find her(this is an all too frequent occurrence. Can you help me get her added back to our leadership ranks?


(removed by Moderator)
BSA #12475680

Any help you can provide is appreciated.

Mike Robinson
Advancement Chair
Troop 237B

@MikeRobinson that user is a Committee member in the Pack in Scoutbook - that is the registered position