Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Parent not able to start or send Messages

I have searched through the forums and still don’t see an answer that has worked.
I have all of our parents set to “view Profile” for all Scouts, but we still have some that when the press the Send Message Icon get nothing.
I had them try it from the main unit page and then again under the Patrol page where their Scout is a member. Same thing. They have tried it on their IOS device and on a desktop. They have logged out and logged back in after I set them again ( 2 times to set them to view profile) and still no change.

Dumb question here, and I’m only asking it because I’ve done this about a million times…

Are they clocking in the right button? There’s a toggles above the message box to switch between email and SMS, and a different button below the message box to actually send the message.

I’ve clocked the toggle by mistake more times than I can count…

Could you elaborate on this? Do you mean that no list of people to send to ever comes up? What do they see?

I’m having the same issue. We are new to Scoutbook this year but every time I click send message, it does nothing. I can click inbox and it moves to a screen showing nothing in my inbox. I tried on both my laptop and iPhone with no success.

Are you saying you never see the list of people to send to?

When you click my dashboard > administration, do you see your own children under my family?

The inbox would only ever contain announcements incoming from (I believe) council. There’s no way that I am aware of for a unit to generate something that appears in Inbox.

When you say it “does nothing”, do I correctly understand it’s as though you never clicked on the button? I’m not sure I have any ideas what would cause that, except a problem with your permissions. If you’re a leader, have you tried going to

My Dashboard -> My Units -> Unit Roster -> Your name

and accepting the positions you have in the unit? They may already be showing as OK, but occasionally my administrator permissions get glitched up and I have to do this to fix things.

Correct. No list, no text box, just the spinning wheel of waiting.
I have at least 1 other parent with the same settings in the Connections Manager that is able to send out messages.
(All adults in our Troop are set to view profile, except 3 whose Scouts have left the Troop, but these are not the parents that are having issues.).
It may be related or not, but one of the parents that can send out messages, cannot create a Calendar event, even though her position is set as Unit Fundraising Chair.

No dumb questions!. They are not even able to get to the screen to type out the message, so that mistake has not yet come up for them… Yet.

Yes! This perfectly describes what is happening to our parent too. I Phone and desktop same results.

Not all leader positions have access to the unit calendar. I believe unit leader, unit secretary, committee chair, chartered org rep, outdoor activity chair, and any unit admin have calendar access.

Thanks, I thought I read somewhere that the Fundraising Chair was one of those positions. I have changed her role to Committee Secretary, so we’ll see if that works.

@ToddDaniels When you click my dashboard > administration, do you see your own children under my family?

I do yes. I am the SM of the Troop and a Committee member of the Pack so everything is working for me. This is in regards to parents in the Troop. I want to use Scoutbook for all communications, but I have to start with everyone being able to start a conversation.
The parent that I have been working with can see their own child and can see his Patrol Members also when she looks under her unit.

I would go to the scout’s page, click the scout’s connections, click the parent’s name, and then click update. That can sometimes reset things.

Just tried that. The parent still cannot use the message button.

The parent can see the patrol members, but not all of the troop members under My Dashboard → My Unit? I just set up a parent with View Profile permissions to all scouts and that account gets me a roster view with all of the patrols listed, and clicking each of the patrols shows the list of the scouts in each patrol.

It’s possible that a unit admin needs to go into Connection Manager under the My Dashboard → My Units → Unit Roster → Connection Manager and reset the permissions for the parents having trouble to View Profile for all of the scouts. It may already look that way, but like the connection to their scout, it might need a kick to get it working again.

She just mentioned that she can see all of the Scouts in her sons Patrol. I am the SM so I have gone in to the Connections Manager and reset all to view profiles for all parents. I have done it for this parent 2 times just to be certain.

What about the rest of the Scouts in the troop? I suggest trying to give her a View Profile connection to all the scouts in the troop and see if this fixes the problem.

Giving her a View Profile Connection is the first thing that I tried, (and then tried again). At this time she can see all of the Scouts if she goes into each Patrol. Under each Patrol she does not see the Send Message button. (she does still see it under the Unit page, but it still does nothing.)

@ToddDaniels - I would be willing to work with the user on a screen share if that helps. Please have them email shornak@bloomberg.net if before 5pm EST.