Print Blue Cards feature doesn't show any results and incorrect address for scout printed on blue card

  1. I’m a SM and trying to print a blue card from SB for one of my scouts, however, when I try to use the print feature, nothing shows up on the screen.

  2. When my Advancement Chair does it, she can see the list and print a blue card, but then we noticed that the scout’s address is incorrect and does not reflect what we see in IA.

@EdwardZee We would need the Scout’s BSA member number in order to take a look.

(No names, please)


Member ID 132429576

@EdwardZee Which city is correct?

Or S.M.?

@JenniferOlinger SM

MP is likely old and doesn’t match what we see in IA.

I have synced the Scout’s address, so they should match now.

Awesome, thanks!

Any thoughts on my first issue of not being able to see any blue cards?

Which merit badge are you trying to print?

What browser are you using?

Swimming MB. Chrome Version 116.0.5845.187 (Official Build) (arm64) on Mac OS Ventura 13.5.2.

I just checked again and now some are showing up for me. Very odd. I couldn’t generate any blue cards for any scout (including my two sons) just 30 mins ago. Now some show up. One of my sons doesn’t appear on the list.

Thanks for all your help!

If you happen to run into this issue again, try resetting your Troop Admin role. In Scoutbook:

  1. Go to the Troop Roster page.
  2. Click on your name.
  3. Click on your Troop Admin role.
  4. Click “Update” to save.
  5. Log out of Scoutbook.
  6. Then log back in.

Actually I see them all now. I was clicking the Blue Card link from My Dashboard and because I’m also a MB counselor, it only showed me the cards for my MBs, but when I go into the unit or individual scout record, they now all show up.

Thanks again!

1 Like

@JenniferOlinger I’m experiencing the same issue again late in the evening. I should see the entire troop’s merit badges, but no results are returned. I tried multiple times to update my Troop Admin role and logout/login, but it didn’t make any difference. This time I am indeed checking from inside the troop and not my dashboard. Any other ideas?

@EdwardZee - did you click update filter… you have to do that much when you change the default settings

@EdwardZee - any luck with what i posted ?

@Stephen_Hornak - No luck. I’ve set a start date, clicked the Update Filter button, and still don’t see anything.

@EdwardZee - it has worked for me without issue

@EdwardZee - I can set up a screenshare if you wish, and for some reason you are missing the line show all scouts

@Stephen_Hornak Sure, a screenshare would be great!

I recall an issue like this and it was all in how you navigate to the BCs - what route are you taking to get there?

My Dashboard → My Units (Troop 358B) → Print Blue Cards

Stephen was able to log himself in and see his blue cards and then tried doing it the same way w/ my account and it didn’t show up. It appeared once at the very beginning and then never came back.

Even if I look at it from my MBC view in My Dashboard, I can’t generate blue cards for the scouts that I’m a MBC for.