User is not authorized to access API

I am DL for a transitioned Webelos>AOL den. I transitioned the den without issue and they show on the roster as expected. I later went to complete a requirement on an AOL adventure and received the ‘user is not authorized to access this API’ error. This is a scout who is not my child and I am unable to complete a requirement on any scout in my den (my child aside). All rank and adventure versions are showing the current 2024 version.

At the time, I had the DL and DA role for that den. My CM gave me the Unit Admin role (added to existing roles) and I was then able to complete the requirement with that role. I later saw on the forum here there is some issues around the AOL DL role so to test we stripped my roles, let time pass, affirmed no access, and then gave me the Den Admin role for this AOL den - no DL role. I still get the API access error and am not able to complete the requirement. I get this error whether I try just completing it without the Approved/Recorded box checked, or with that box checked as well.

Any ideas why this might not be working? I have my unit role selected in the upper right. The DA role lists in Scoutbook and is the role listed in SB+ in the upper right. Hard refresh doesn’t change the behavior. I get this in both Edge and Chrome. BSA ID 13422385.

Same exact situation here-- Leading an AOL patrol, trying to approve the Swimming Adventure-- hoping we get a great reply & easy solution! BSA ID 140560904.

I’m trying to attach a screenshot, for what it’s worth…
Screenshot 2024-06-13 at 8.09.17 AM

both your admin positions might be TOO new - it can take up to 48 hours for positions to get to SB+

Okay-- that makes sense! I’ll check again this weekend, and see if my position has made it’s way through the system. Hopefully that solves the problem for me & Jared as well! I’ll try to post back to provide some closure for others who may search this topic, if that’s all it is!

Scoutbook says I’ve had this new DA role for 3 days now. I just tried and am getting the same API error. I tried a shift-reload, no effect.

Tried doing the same Batch Entry procedure for the Swimming award-- getting a differently worded error now, for what it’s worth-- but (same as Jared) no dice on any entry.

However, when I try to approve individual requirements for an individual scout, I still get the API warning.

I’ll try again tomorrow, to test the 48+ hours theory for my account…

Continues to not work today; all circumstances the same. I tried approving another Adventure item that needed to be approved, just to see if the Swimming Adventure was specific to the problem-- not the case. Summertime Fun Adventure also didn’t work.

@DonovanMcNeil, the problem persists for me. For what it’s worth, when I first login to Scoutbook+, I have to shift-refresh EVERY time, to see my Den Admin status as an option in the upper right selection menu.

Still getting this error every time I try to batch approve my four AOL scouts for the Swimming Adventure (earned on June 1st-- dunno if THAT causes any problems, as it was the first day of the new requirements):

I CAN add comments to my AOLs Swimming Adventures individually, but when I try to individually approve requirements of the adventure, I get the API error:

Please help me resolve this-- it’s driving me crazy. I want to be able to show my Scouts that it can be fun / rewarding to Scout in the summer… I have the pins in hand, ready to award from the ScoutShop, but I know at least one parent in my patrol that’s an old-school Eagle, who frequently checks Scoutbook, and will probably cry foul if I give the pins out before the record is correct-- I’ve already been told that it’s not courteous/helpful to make the kids wait, and that a Den Leader needs to be trustworthy, to upload documentation. Asking humbly for help, please.

Yeah, I found I can add people to my den but still can’t log progress. From reading others’ posts, it’s pretty clear something isn’t working correctly for requirement completion. At least for AOL dens. I’m waiting to hear back if leaders/admins of other dens in my unit have the same issue. I’m curious if our issue is related to comments about AOL den leadership being not fully up and running in SB+ yet. I’m sure they’ll squash this bug eventually.

I find it positive that I have scouts in my den knocking out requirements this early and over the summer. This is a good problem to have.

@JaredGilbert if you want I can setup a screenshare to take a look

Sorry to jump in on the invite-- but, @DonovanMcNeil, may I setup a screenshare appointment with you?

@tristandalley it is the whole den and not just your own kid?

correct-- having problems individually with each patrol member, as well as my own son.

I will send you a direct message > look at top right Avatar to find it > it will be a green envelope > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

1 Like

I would but can’t, as I’m at work. Whatever you find out with Tristan, May apply to me too, so let me know how your session goes and what you learn.

Same for me. I cannot complete requirements for any scout in my den. I’m not even trying for my child currently.

The one thing we did not look at - can one of you click edit den and make sure you are listed under the den

Yes, I am listed in the “adults in den”.

1 Like

Yes, I am listed as “Adults in Den.” @JaredGilbert , @DonovanMcNeil was really helpful-- we didn’t get to the bottom of the problem, but we DID capture a big chunk of code that DESCRIBED the problem… he was sending it on for processing!

So, no solution thus far, but hope springs eternal!

1 Like

That is good progress. I appreciate you were able to do that screen share session.